Canon Community Canon Community
 


Reply
Highlighted
New Contributor
Posts: 1
Registered: ‎04-08-2015

Error 5100 on MX922

[ Edited ]

Hello,

 

This evening run into an error 5100 om my MX922. First tried to check if it is really a paper jam but nothing was found. Then tried to re-insert ink cartridges to no avail...

 

Here's the symptoms - once turned on, printer successfully goes thru self-init sequence. Scan works with no problem. Once I try to print anything (or make a copy or print from a template), it starts and then in 5 seconds it beeps and displays error 5100. Of course, I went to a kb article:

http://kbsupport.cusa.canon.com/system/selfservice.controller?CONFIGURATION=1011&PARTITION_ID=1&secu...

 

No success.

 

Updated to FW v.3, no success either.

 

It looked to me like something is wrong around the print head. Then, to satisfy my curiosity I detached right side cover and discovered a reason - please see the photo.

 

Here's the reason:

The head (obviously, before each printing) goes thru a quick cleaning procedure and then slides to the left but the cleaning pouch (black rubber piece on a white plastic lift) stays in UP position and when head returns back it simply hits this constructions and immediately displays error 5100.

 

So the question - has anybody seen such a behaviour? Is it a catastrofic and printer needs to be thrown out or it can be fixed?

 

Thanks for any help.

 

20150407_222514.jpg

Product Expert
Posts: 1,989
Registered: ‎10-17-2012

Re: Error 5100 on MX922

Hi pas922,

 

If removing and reseating the ink tanks and print head in the printer did not resolve the error, the printer will require servicing; please call or email us using one of the methods on the Contact Us page for information on servicing options available to you.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
New Contributor
Posts: 1
Registered: ‎09-10-2019

Re: Error 5100 on MX922

I had the same problem, where the printer would go through the start-up cycle, it is successful the first time, and if I opened the door to change ink cartridges, the printer cartridge carriage would move to the middle.  If I closed the door, it would go through a 2nd successful cycle.  If I opened the cartridge door again, it would move the printer carriage to the middle, but when I closed the door again, it would try to cycle, however, the carriage cleaning base would pop up too soon, and the carriage would get jammed against the print head cleaning base.  There should be two springs in the opening you see here.  Instead, it looks like one of the little black plastic fingers broke, and I found a little spring in the hole.  I took the printer apart in an attempt to put the spring back into place to no avail.  I suggest getting a new printer.  These tiny little plastic fingers most likely will break in 5 years or so.  I ended up taking most of the printer apart to attempt to fix.  There are many gears involved so hard to tell if I can successfully get the printer back together.  Super hard to reattach the spring, and what do I attach it to?  I may try gluing on something to attach the spring to, but I have found I needed to dismantle this part of the printer in order to get into the tiny little hole this spring is in.  I like the MX 922, other than it is obvious they did not build this to last more than 5 years or so.spring missing.jpg

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement