Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎07-11-2019

Does macOS Mojave 10.14.5 work with my Canon MP 620 printer/scanner?

Here's what I have:

 

macOS Mojave 10.14.5

Canon MP 620 printer/scanner

 

and the old MP Navigator EX 2.0 software that enabled me to scan (up until we got the Mojave OS).

 

Is it true that the old MP Navigator has been replaced by My Image Garden?

 

Here's my question:  Can I download the new My Image Garden and still use my MP 620 printer for scanning?  Or do I need to go buy a new printer/scanner?

 

Thanks in advance.  I am very much not computer savvy.

Highlighted
Product Expert
Posts: 1,973
Registered: ‎07-28-2014

Re: Does macOS Mojave 10.14.5 work with my Canon MP 620 printer/scanner?

Hi InkBlot,

 

The PIXMA MP620 is not supported with macOS v10.14.

 

You are eligible for Canon's Upgrade Program.  This is for out of warranty units which have been diagnosed to require service, or for some reason are incompatible with a new or upgraded system.  This option allows you a one-time opportunity to purchase a replacement product, discounted from the list price.

 

To help you get up and running quickly, we also offer free standard shipping (if the order is completed by 12:30PM ET).  If you would like to take part in this option, please call our Sales Department at (866) 443-8002 seven days a week, 8am to Midnight.  Let them know you have been working with technical support and the Canon Upgrade Program was offered.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement