Canon Community Canon Community

New Contributor
Posts: 2
Registered: ‎11-23-2014
Accepted Solution

Canoscan 88ooF error report, "Cannot communicate with scanner."

[ Edited ]

When I try and use my scanner I get the error report,"Cannot communicate with scanner, check that it is plugged in and truned on." When I go to Windows device manager I can see it and when I click on the properties buttonn it says that the device is working properly. I have downloaded the latest driver software etc., and I have uninstalled everything and re installed again but I still get the same error report.


I am using Windows 7, 64 bit version.


Screenshot 2014-11-23 15.06.png


Above is the error message I get.

New Contributor
Posts: 2
Registered: ‎11-23-2014

Re: Canoscan 88ooF error report, "Cannot communicate with scanner."

After two days of fruitless effort I have found my own solution. I have downloaded and installed VueScan  x64 and it works a treat. I think the problem I have been having is due to the fact that the scanner driver is 64 bit and the programs that install are 32 bit and although scanner driver is working perfectly well the 2 bit probrams can't see it.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement