Canon Community Canon Community

New Contributor
Posts: 2
Registered: ‎12-23-2019

Canon ScanGear configuration under Linux

Hello !


I am using my Canon MG5300 printer with ScanGearMP and Linux Mint.


Unfortunately the ScanGear window opens in an unusefull shape every time I open it.

Also the configuration of the settings need to be repeated every time I start it.


How could I modify windowsize and setting defaults ? Coudl I start scangearmp with -options ?


Thanks so much for your support !



Esteemed Contributor
Posts: 3,534
Registered: ‎11-19-2017

Re: Canon ScanGear configuration under Linux


ScanGear MP v1.80 was released over 9 yrs ago.  I would not count on it to run under Mint Distro.


Start here, but your questions goes beyond the scope of the Canon forum.


Happy Holidays



Bay Area - CA
~6D2(v1.1.0) ~Many Lenses ~DxO PhotoLab Elite ~Windows10 Pro ~EVGA RTX 2080 FTW3 Ultra ~Pixma Pro-100 ~ImageClass MF644Cdw ~LBP622dw
New Contributor
Posts: 2
Registered: ‎12-23-2019

Re: Canon ScanGear configuration under Linux

Hello Rick,


thanks for the answer, sorry I did not make my intention clear.


As Win7 will not be supported any more in Jan. 2020 and Win10 is not an option for me I started using Linux Mint.


But I don't want to scrap my Canon pinter, with wich I am quite happy, just because of the switch to Linux.


Therefore I am woundering if there is any documentation about the ScanGear MP v1.80 driver.


Are there any options that I could start scangearmp with ?


Happy New Year 2020 !!

New Contributor
Posts: 1
Registered: ‎03-09-2020

Re: Canon ScanGear configuration under Linux

The following process worked for me. First, let me hasten to say I am by no means a Linux guru. So, forgive me if my description lacks the presion of terminology that those proficient in Linux are used to.


After downloading (from Canon), unpacking and installing the Debian printer and scanner drivers for my Maxify MB 5120 in Lunix Mint 19.3 Cinamon, I found that the printer side worked fine but that the scanner was not showing up in Simple Scan. This is a commonly reported problem. I should add that this Canon MFP is directly connected to my my router, not a direct USB connection to the computer. So it is a "networked" device.


After researching this issue and trying different suggested fixes the involved terminal commands and script edits that did not work, I went back to Downloads and exectuted the scanner installer again. Mint makes this easy by just a double click with the mouse, like Windows. This time, however, I got a message popup saying the package was broken and that I needed to fix it with Synaptic. There were a couple of terminal scripts given to facilitate this but the long and short of that was I just needed to open Synaptic Package Manager and execute the "Fix Broken Packages" tool found in the "Edit" tab of the Synaptic PM GUI. 


Once the broken package was fixed, if I recall correctly, I typed in "scangear" and Snaptic fetched the Scangear driver driver package and you could see the list of Canon MFP models it covered. I clicked on the box for my MFP model which then generated a popup asking permission to install all related "dependencies" for which I gave approval. I clicked on "Apply" and Synpatic did the rest. After that processed was finished the scanner showed up in Simple Scan and I was able to scan without issue.


In retrospect, I'm not sure that I didn't create the "broken package" problem with all my other attempts to fix the issue. I have a hunch that the real fix was just to going to Synaptic Package Manager, seaching for the scangear driver, satisfying the dependencies and checking the box for my model.


Hope this helps someone.scangear.png

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement