Canon Community Canon Community

New Contributor
Posts: 3
Registered: ‎10-07-2017
Accepted Solution

Cannot scan with TS8050: scan error 2,157,50 and 5,167,59

[ Edited ]

I just installed my new TS8050. Printing works just fine, but I can't scan.


I have updated the printer's firmware to 1.150

I operate under Windows 10. I have installed Canon Quick Menu v2.7.1

The printer is connected to the same Linksys WiFi router than my PC. The printer screen says I have 59% signal strength.


I don't have any pb printing.

When I select 'Printer Status' in Canon Quick Menu, I get all the info (see screen shot). So far, there is no pb.


Now I want to scan and things get out of control:

When I launch ScanGear, I hear the scanner moving. But I get the error 2 157 50 as you can see below.

I've tried to deactivate my firewall (Kaspersky), but then I get a different error from ScanGear: 5,167,59

I have tried to use Paint to scan, but it's not working either: when I ask for the preview, I can hear the scanner moving, and after a long wait, Paint says it is 'unable to get the image from the device'.

I have also tried to launch a scan from the printer's own touch screen. I chose 'save to computer', I select my PC, and press on the green logo. I can hear the scanner move, but after a while, I get the same 2 157 50 error.

Printer Status is OK.png

ScanGear Error.png


I have logged with the PC's admin profile and the pb remains.


It looks to me like the file of the scanned image itself can't travel from the Canon to the PC. Weird. Your help would be greatly appreciated!

New Contributor
Posts: 3
Registered: ‎10-07-2017

Re: Cannot scan with TS8050: scan error 2,157,50 and 5,167,59

I found the solution!


The pb did not come from the printer, but from my router and LAN set up.


I had tried a few fixes, such as rebooting my router, changing firewall on the PC, or activating the WSD port in windows. It seemed to temporarily enable me to scan, but after awhile, the problem resumed.


So, here is how I fixed the pb for good:

- in my router (Lynksys) set up, I assigned a fixed IP adress to the printer (which I've identified with its MAC address)

- then, for that IP address, I set up a DMZ, to allow all outbound/inbound traffic


I've done that since a week now and the scan pb never resurfaced. I can scan either from the Canon software, or from the printer menu.


Note that I had written to Canon France. They opened a ticket and replied a few days later, asking that I bring the printer to a local maintenance shop. Wrong answer. It wouldn't have help at all in my case.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement