Canon Community Canon Community

New Contributor
Posts: 1
Registered: ‎07-18-2017

Cannot connect to wifi

I just got a wireless MG 7120 and cannot get it to connect to my wifi network. It can see all of my neighbor's networks but does not see mine. When I use the Canon IJ Network Tool, I am unable to see my network, and when I manually enter the details, it says the password is not correct. I have tried to enter the details on the go, tried downloading the go, reloaded the go...have no idea what to do next. The whole reason I got this was so I did not have to rely on a USB cable to print. Any help would be great. 


I am running OS 10.12.5

Product Expert
Posts: 3,253
Registered: ‎10-16-2012

Re: Cannot connect to wifi



Since you are able to view other networks, the issue would be related to your current network.  Make sure that the SSID is being broadcasted and also ensure that the router is operating on the 2.4GHz frequency band.  Contact your router provider or manufacturer for assistance with these particular settings.


This didn't answer your question or issue? Find more help at Contact Us.



Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement