Canon Community Canon Community

New Contributor
Posts: 1
Registered: ‎08-17-2020

Cannot connect MacOS Catalina to TR8500 by wifi, but can by cord

I recently upgraded my Mac to OS Catalina and cannot connect by wifi to the printer. It was fine before, and my wife is fine on her PC still connecting and printing. I deleted my print drivers and reinstalled the TR8500 drivers, and could only connect by a USB cable. I cannot connect by wifi. It says "printer offline", but yet I'm using the internet by my wifi to compose this note. 


I can print when connected by a printer cable, so all is not lost. But it seems that a wifi connection should be obvious.


Is anyone else experiencing this issue on Mac OS Catalina with Canon printers? I'm wondering if there is an issue? I tried entering the iPv4 IP address during setup and that didn't work, nor did trying to use the Bonjour name. Neither worked. If it's any help, I'm on a 2012 MacBook Pro that is the bottom of the list of supported models for OS Catalina.

Reputable Contributor
Posts: 858
Registered: ‎11-13-2019

Re: Cannot connect MacOS Catalina to TR8500 by wifi, but can by cord

Hi DavidB341.


When a computer's OS is upgraded to a newer version, often times the core settings are also changed. Check whether your computer is connecting on a 5 GHz wifi connection and, if so, try connecting it instead to a standard (2.4 GHz) wifi connection.  To confirm whether the router is allowing communications, you can try opening the TR8520's Remote UI.


In the Case of Mac OS Catalina, the drivers on the installation CD will not work; you'll need the latest version of the drivers, available on the 

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement