Canon Community Canon Community
 


Reply
Highlighted
New Contributor
Posts: 1
Registered: ‎08-04-2018

sx260hx - can't pull photos off

This camera works fine on a Win10 unit (using same cable, same card - only have the one). All i need to do is wait until it pops up in the Windows Explorer window, then open it up and copy the images where i want them.

 

However, on a Win7 unit the camera never appears in the Windows Explorer. Device Manager sees the camera when connected and powered, listed under "Portable Devices" with an alert badge. however, when i tell it to update the driver, it searches and returns that the software is the most up-to-date available. ("MTP USB Device")

 

i've downloaded the "CameraWindow DC 8.10.4a" and "ImageBrowser EX" from Canon and installed them; CameraWindow first, and when the camera still didn't appear in the Windows Explorer i installed the ImageBrowser. When i opened that app and told it to pull images from the camera, it said it couldn't find a camera (it was still showing in Device Manager, though, so i knew it was powered on and connected).

 

i have used this camera both on Win7 (a different unit that died) and Win10 with the same cable and card for years. i take photos of product to go up on a shop website, connect to the computer, copy the images over manually, delete the images from the card, then disconnect - so i know that this should work. i've deleted various drivers that this unit no longer needs to make sure that they aren't interfering, and still the camera appears in Device Manager but not in the Explorer window.

 

oh, i should add that i've tried every USB port on this unit, and tested those ports with keyboard and mouse as well. The ports are good, and the camera is seen in Device Manager through all of them. The computer has no other peripherals attached.

 

It's Win7 64bit. i am a computer repair technician, so i do this sort of troubleshooting all week long. usually i can just replace a malfunctioning unit with one from stock and repair it later, but this is for my second job and we don't have extra equipment here. i hesitate to restore the unit to factory, as it would probably take DAYS to run all the Win7 updates!

 

thank you!

Highlighted
VIP
Posts: 9,661
Registered: ‎08-13-2015

Re: sx260hx - can't pull photos off


@aellath wrote:

This camera works fine on a Win10 unit (using same cable, same card - only have the one). All i need to do is wait until it pops up in the Windows Explorer window, then open it up and copy the images where i want them.

 

However, on a Win7 unit the camera never appears in the Windows Explorer. Device Manager sees the camera when connected and powered, listed under "Portable Devices" with an alert badge. however, when i tell it to update the driver, it searches and returns that the software is the most up-to-date available. ("MTP USB Device")

 

i've downloaded the "CameraWindow DC 8.10.4a" and "ImageBrowser EX" from Canon and installed them; CameraWindow first, and when the camera still didn't appear in the Windows Explorer i installed the ImageBrowser. When i opened that app and told it to pull images from the camera, it said it couldn't find a camera (it was still showing in Device Manager, though, so i knew it was powered on and connected).

 

i have used this camera both on Win7 (a different unit that died) and Win10 with the same cable and card for years. i take photos of product to go up on a shop website, connect to the computer, copy the images over manually, delete the images from the card, then disconnect - so i know that this should work. i've deleted various drivers that this unit no longer needs to make sure that they aren't interfering, and still the camera appears in Device Manager but not in the Explorer window.

 

oh, i should add that i've tried every USB port on this unit, and tested those ports with keyboard and mouse as well. The ports are good, and the camera is seen in Device Manager through all of them. The computer has no other peripherals attached.

 

It's Win7 64bit. i am a computer repair technician, so i do this sort of troubleshooting all week long. usually i can just replace a malfunctioning unit with one from stock and repair it later, but this is for my second job and we don't have extra equipment here. i hesitate to restore the unit to factory, as it would probably take DAYS to run all the Win7 updates!

 

thank you!


Use a USB card reader.

----------------------------------------------------------------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."
Highlighted
Reputable Contributor
Posts: 704
Registered: ‎10-18-2016

Re: sx260hx - can't pull photos off

I used to be a service engineer too so hopefully my questions won't appear too daft.

 

1.  Have you tried switching SD cards in the camera, taking a few photos and then trying to reconnect?  My concern is that the card itself may be the issue.   If, for example, the card was removed without going through and undocking process I have known them to be ignored thereafter by the computer.

 

2. Have you tried the card and a control card in a computer SD cards slot?

cheers Trevor
"All the beauty of life is made up of light and shadow", Leo Tolstoy;
"Skill in photography is acquired by practice and not by purchase" Percy W. Harris
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement