Canon Community Canon Community
 


Reply
New Contributor
Posts: 3
Registered: ‎10-09-2015

Re: shutter release not working S100

do you know where I can buy the part??

 

 

thanks,

Highlighted
Occasional Contributor
Posts: 6
Registered: ‎09-01-2015

Re: shutter release not working S100

Call Canon parts: 866-481-2569
Request part CM1-7226-000 "FPC ASS'Y TOP" (Flexible Printed Circuit Assembly, top of camera)

Cost is $18 with shipping.

 

Direction you should go back to page 40, post 400. Watch out of the main connector. Goodluck.

New Contributor
Posts: 3
Registered: ‎10-09-2015

Re: shutter release not working S100

thank you!!!!

New Contributor
Posts: 1
Registered: ‎10-29-2015

Re: shutter release not working S100

[ Edited ]

Hello all!

 

Just repaired my S100.

Ordered FPC from Conventa here in Sweden [link removed per forum guidelines]. The price is about the same + domestic shipment.

 

I want to point that that (relatively) big connector for the Top FPC has a lock (the black part of the connector) and you better release it. Otherwise you may damage the connector (like I did). I managed to fix the connector afterwards but you better release the lock Smiley Happy.

 

That you everybody for information gathered here!

New Contributor
Posts: 1
Registered: ‎12-30-2015

Re: shutter release not working S100

After a "professional" repair for >100 EUR solved the problem only for a few shots before AGAIN my S100 would not trigger anymore, I decided to try it on my own. 

 

In Germany you cannot get the replacement part directly from Canon.  WHen I called  Canon they pointed me to this company:

 

oKam GmbH - Technischer Service
Spengler Allee 11
D-04442 Zwenkau

 

Tel.     +49 (0) 34203/51803
Fax.    +49 (0) 34203/51804

eMail:   info-okam@okam.de

Web:    www.okam.de

 

This worked really quickly.  Cost was 27 EUR incl. shipping.

 

I followed the detailed instructions of post 400 (kudos!) and it worked like charm.  I also took photographs of the different stages of disassembly and repair.  If this would help anybody, please let me know and I can post them somewhere.

 

Now the weird part:  I was obviously curious to understand what causes the release switch to fail.  The white polymer cover on top looked dented and I assumed that the switch was damaged by too much pressure.  So I broke the part off the FCB and disassembled it.  To my surprise, I could not find any damage at all!  The middle contact platelet looked slightly darker than the other parts, as if it was oxidized, but the electrical contacts all worked.  Also the mechanics with both trigger levels worked fine and I could not find anything that could explain the malefunction.

 

Any insights here!?

 

Frequent Contributor
Posts: 93
Registered: ‎03-28-2015

Re: shutter release not working S100

The fact that cleaning with DeOxit sometimes works for a short while strongly indicates that the overall problem is oxidation of the contacts. When the problem returns I suppose that the cleaning was not thorough enough. Or the switch contacts might have a thin layer of gold to prevent oxidation. That is a common feature for instrument switches. Once that layer wears off, cleaning may only give short-term relief. When the problem is intermittent the user may get in the habit of pressing too hard and deforming some mechanical components of the switch. Perhaps the shutter switch still works when tested with a meter, but may have a high resistance due to oxidation, and the high resistance reduces the voltage enough for the shutter to fail to trigger. Remember, the camera is designed to work with very low current drain. But all of that is just theory, and I would not be surprised if the answer lies elsewhere. My guess is that your "professional" repair consisted of spraying the shutter with cleaner -- which only works for a week or two. So, if you still have the bad switch, try to measure the actual resistance with a high impedance meter. If the resistance is more than a couple of ohms the theory is supported. Then you can disect the switch and examin the contacts directly to look for traces of gold plating, with evidence of wear. I look forward to the next chapter in your investigation. 

Occasional Contributor
Posts: 7
Registered: ‎01-03-2016

Re: shutter release not working S100

Hi,

 

I have got the same problem and Canon in Germany is again unwilling to fix this well known and obvious bug. I ordered the spare part and was able to replace it like mentioned in post 400. Thanks to all and especially jimpgh for the help. However after assembly the camera sems to be dead - no reaction at all. Before I was able to make videos and reply fotos and videos (and take pictures from time to time). Could I have damaged something ? Everything went smooth when reasembling the camera... 

So far I did not use this DeoxIT.

Any ideas ?

 

Thanks and best regards

 

Frequent Contributor
Posts: 93
Registered: ‎03-28-2015

Re: shutter release not working S100

The most problematic part of the repair is re-connecting the main connector. Try re-seating it.

Frequent Contributor
Posts: 93
Registered: ‎03-28-2015

Re: shutter release not working S100

Martin, take a look at posts 317 and 373. Maybe a little wiggling and added pressure on the main connector will give results. But take your time. No pliers.

Occasional Contributor
Posts: 7
Registered: ‎01-03-2016

Re: shutter release not working S100

Hi Dan,

 

thanks for your advice. I have tried it again and even checked the main connector contacts with a magnifier. Everything looks good and I am sure that the main connector is mounted correctly. However no results - also not in replay mode. 

It is really a nightmare.

 

Still wondering how Canon can allow to fool customers like this and it is not for the first time. Once had a problem with another Canon of my girl friend (PowerShot A540) which showed exactly the same problem like explained in an official Canon service note. The answer from Canon was that my serial number is not affected by the problem..

so there seems to be some kind of systematic in the way Canon is "handling" such issues and thats why this was the last Canon for me. 

 

The only positive thing about this is that since the camera isn't working I am using my full frame DSLR more often again which is bulky but works - always (it is not a Canon...) 

 

best regards

 

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement