Canon Community Canon Community
 


Reply
Occasional Contributor
Posts: 7
Registered: ‎11-18-2014

Re: shutter release not working S100

Hello,

 

I have not posted in awhile and I did not read the continued postings on this thread, but I thought I would update my status.

In December 2014 I took my camera apart and I did use the DeOxit on the shutter release button internally.  The camera really has worked well up until last weekend.  Unfortunately I now get the lens error message and the camera will not work.  I called Canon and my camera's serial number is not part of the lens recall.  I have given up and I will not try to fix the camera at this point.  I was happy with the camera except having these two major issues.

 

I bought my wife a DSLR yesterday to replace this camera.  A size difference I know but it will not have the lens error potential.  It will be nice to have a good camera to take some good quality photos.  I always have my iphone with me for the times I dont plan on taking photos anyway.  For me this was the right decision, but unfortunately for the readers of this thread it may not be what they wanted to hear.

 

Good luck everyone... up yours Canon!

Frequent Contributor
Posts: 92
Registered: ‎03-28-2015

Re: shutter release not working S100

Try spraying deoxite externally on the shutter button, with the button depressed.
Respected Contributor
Posts: 1,298
Registered: ‎03-01-2014

Re: shutter release not working S100

Those lens assemblies new go for cheap money like $20 but you'll have to take the camera apart again if you've not completely given up already

Occasional Contributor
Posts: 7
Registered: ‎11-18-2014

Re: shutter release not working S100

Thanks John,

do you happen to know the part number and where I can buy the part?  I live in Canada

Respected Contributor
Posts: 1,298
Registered: ‎03-01-2014

Re: shutter release not working S100

If you do a search on an auction site like ebay for Canon S100 lens assembly youll find it I dont have any part numbers for that, I didnt take notice of them..if you call Canon they might provide it for you

Frequent Contributor
Posts: 92
Registered: ‎03-28-2015

Re: shutter release not working S100

You will need the shutter part and the lens assembly. The shutter part is: CM1-7226-000 FPC ASS'Y, TOP
I suggest calling Canon repair parts 866-481-2569 and tell them which camera you have and they will help you.
Frequent Contributor
Posts: 38
Registered: ‎06-13-2014

Re: shutter release not working S100

Smiley Happy it seems enough people are having luck with this, so that's a good idea!
New Contributor
Posts: 1
Registered: ‎06-03-2015

Re: shutter release not working S100

Hello,

 

Just wanted to add my voice to this and thank you people on the forum. I had the same shutter release problem with my s100. I have had it for 3 years and have used it fairly minimally. I had the same experience with Canon wanting to charge $164. I tried to complain but they said not enough people have that problem and that on the internet you will always find people with the same problem but it doesn't constitute a known fault. No luck there so I decided to give it ago myself.  I have no experience taking apart cameras but thanks to the detailed advice on this forum I was able to make it work again. The part number in the camera was 7226-020 but the one I replaced it with was 7226-030. I took the six outside screws out and took off the two sides of the outer assembly of the camera (don't do this too violently as the front part is attached by a thin piece of circuit. Then I removed one screw holding on the top plastic assembly on the side of the camera and one just above the lense. Then I removed the top plastic assembly and removed the two screws that hold the white box thingy on top. It was very cold in my house so the old FPC Assembly came off quite easily. Like others have mentioned the hardest part is to get that slide in connector in. I was really sure I was going to stuff that up but if you just keep trying you will get it in eventually. Anyway to my surprise it worked. I am from Australia and I ordered the part from a website called mediaform. 

 

So to all the people who posted detailed instructions thank you. Also a question: do you guys think that a few years down the track this part will still be available? Or would it be wise to buy another now just in case? The part was 50 AUD with shipping so I am not too keen for that. 

 

Best, G

Highlighted
Frequent Contributor
Posts: 92
Registered: ‎03-28-2015

Re: shutter release not working S100

Congratulations on successful repair. Hard to say about future availability of the part -- or if you will ever need it. The price (with shipping) is about $18 in the US. Maybe you know someone who will be traveling, since you are in no hurry for the backup part. I thought about getting a spare, but will not since who knows what other failure may occur over the next 3 or 4 years -- or what technical obsolescence may occur. For others, the time to order the spare is when you first order the part, since shipping costs the same for one or two, or possibly a few.
New Contributor
Posts: 2
Registered: ‎07-07-2015

Re: shutter release not working S100

My shutter failed same as everyone else's.  I decided to go the replacement route.  Here is a detailed report of

what I did.  Hopefully someone finds it useful.

 

Call Canon parts: 866-481-2569
Request part CM1-7226-000 "FPC ASS'Y TOP" (Flexible Printed Circuit Assembly, top of camera)

Cost is $18 with shipping.

 

Note: The part that was removed from the camera was marked 7226-020 (small writing near selector switch.  The

part that I received from Canon was marked 7226-030.  The packaging and order number were both 7226-000.

 

Tools you will need:
Small philips screwdriver, either "00" or "000" size.
Sharp pick of some sort
Optional: fine tweezers, guitar pick

 

1. Start by removing the six visible screws on the outside of the case.  If your screwdriver fits these you'll

have no problem with the rest.  These screws are all the same length.  Set them aside in one pile.

 

2. Remove the front and back covers.  Be careful when removing the front cover as there is a flex cable

connecting the front adjustment ring to the camera body.  The cover for the USB and HDMI ports will fall off in

this process.

 

3.  I recommend unplugging the adjustment ring flex cable.  This allows more freedom in manipulating the body of

the camera in the next steps without the possibility of damaging the cable.  Before unplugging the cable note how

it flows from the camera body to the front cover with no twists.  This is important during re-assembly.  Gently

pull on the cable to remove it from the white connector on the camera body.  Alternatively you can use your pick

to pull out the connector using the small hole in the cable near the connector.

 

4. Remove the top cover by first removing two screws, one just above the lens and one on the side below the

selector switch.  These screws are different length.  Set these aside in a second pile.

 

5.  Separate the connector behind the flash pop-up.  You can use a finger nail or the guitar pick to do this. 

Look at the new part and it should be obvious how to do this.  The top half of the connector just lifts off.

 

6.  Remove the GPS antenna assembly.  The is the white rectangular block above the lens.  There are two screws

holding this in place.  One is plainly visible, the other is near the connector that was just separated.  You
will need to lift the flex tail that is held in place with a mild adhesive.  You can let the GPS PCB (printed
circuit board) assembly hang.  There shouldn't be much stress on it.  Under the GPS PCB is a metal tray. 
Wiggle that out too.

 

7.  Open the connector that connects the top FPC to the rest of the camera body.  This is done by flipping up the

latch mechanism, which is the black bar on the white connector.  The black bar is on the side of the connector

away from the cable.  Use the guitar pick or a fingernail.

 

8.  Remove the top flex assembly.  Note that the flex tape is positioned by six posts.  Four are plastic, two are
metal.  Lift the flex off of these posts.  In the area of the selector switch the flex is held down by some
fairly aggressive adhesive.  Use the guitar pick to work it loose.  You will likely dislodge one or more of the
components on the flex tape in the process.  There's no turning back now!

 

9.  Install the new flex tape taking care to make sure that it is correctly located over each of the posts.
Insert the tape into the main connector and close the latch.  Snap the two connectors together near the flash. 
Make sure that the focus LED is correctly positioned behind the plastic retainer.  You have to lift it
and slide it down behind its retainer.

 

10.  Reinstall the GPS antenna tray and antenna PCB.  It takes a bit of wiggling to get it in place correctly.
There is a black plastic retainer just above the left side of the lens that holds the GPS antenna flex cable
in place.  Ensure that the cable is behind this retainer.  The shorter screw goes nearer to the flash.

 

11.  Replace the top cover and the two screws that hold it on.  The longer screw goes near the lens.

 

12.  Reinstall the front ring cable.  Line up the cable in the socket and use the pick through the hole to
push it in.

 

13.  Replace the front and back covers.  There is a foam dust ring that goes around the lens (it may still be in
the front cover.  Make sure that this is correctly positioned over the lens.  As you snap everything
together, make sure to include the port cover as well.

 

14.  Replace the six external screws.  Test everything out to make sure it is working properly: shutter,
selector, flash, ring, etc.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement