Canon Community Canon Community
 


Reply
Highlighted
Occasional Contributor
Posts: 12
Registered: ‎11-09-2014

Re: shutter release not working S100

I'm pleased to announce that after a week and close to 1,000 shots my S100 shutter problem appears to be gone.  I removed the 6 perimeter screws and shot some Deoxit Gold (not D5, simply what I had) into the shutter button contact spot from the front, put it back together, and haven't had one problem since.  The only issue I see, and it's my own fault, is that my rear LCD screen has developed a slight dark spot across the top, sort of like a graduated filter, which, I believe, is from me squirting too much Deoxit in from the front.  I didn't give as short of bursts as I probably should have and I'm sure internal parts are somewhat caked.  Hesitating taking it apart to see if I can whipe some of the excess out of the innards since the camera's working fine now.  Not a deal breaker, and, like I said, my fault.  But the major problem appears to be whippped.  If that changes i'll post to the forum.  Thanks for the Deoxit idea!  Just saved me ~$400 (was going to purchase a Sony DSC-RX100).

Respected Contributor
Posts: 1,333
Registered: ‎03-01-2014

Re: shutter release not working S100

Thats good news !

Deoxit doesnt tend to cake by itself and it stays fluid and the Deoxit D5 has 3 adjustable levels of spray power, H, M and L.

I'd wait to see if the LCD clears up by itself before messing with it again.  You didnt have to take the screen out to do what you did right? Im just thinking of a connector that may have gotten loose or moved. Or you put to much pressure on it when taking it apart ?

The wrorse that can happen is you can use it as is now right and the best is it could clear up over time and either way you saved a lot of money !

 

Occasional Contributor
Posts: 12
Registered: ‎11-09-2014

Re: shutter release not working S100

Nope, didn't have to take the screen out. I think I just shot some Deoxit onto the back side of it when applying to the shutter button contact area since I was spraying front-to-back. Yep, very happy my S100 has some more juice left in it and I don't have to scrap it after only 2 years.
Occasional Contributor
Posts: 7
Registered: ‎11-09-2014

Re: shutter release not working S100

[ Edited ]

John Said "

No company is perfect and this whole scenario can probably be found in one form or another in other forums for other manufatcurers. 

What would have set Canon apart in a postivie light would have been a proactive approach to resolving this issue for all it's customers by fixing their cameras under a recall.

Instead you had to "sing for your supper". That places Canon right back in the middle of the herd of manufaturers."

 

You are correct John. Canon is a large company and as a large company it is hard to create a perfect stream lined process for all the issues that come up which is why I may still consider another Canon camera in the future unless another company convinces me they care to go above and beyond what the current state of affairs seems to be by all manufactureres. But for now it's hard to say that Canon is any worse than their competitors in regards to how they handled my issue. In the end they came through, even if they did need a little push from me and the BBB, but still came through none the less. So far everthing is functioning perfectly so as I said before, I'm a happy camper!(-:

Occasional Contributor
Posts: 7
Registered: ‎11-18-2014

Re: shutter release not working S100

DeOxit is NOT a permanent fix.  I just got back from a weeks holidays and the camera is starting to act up again.  It is not near as bad as it was but it is starting to get worse.

 

I will DeOxit again.

 

Canon really should read this forum and offer to fix their defective camera.  This is obviously a defect in the camera series.

 

 

 

 

Respected Contributor
Posts: 1,333
Registered: ‎03-01-2014

Re: shutter release not working S100

Sorry to hear yours is acting up again.

That is why I suggested several posts back to that person who got Canon to fix his for free to take as many pictures as possible before his repair warranty ran out. Canon might have used Deoxit on his too.

 

You woud know better than I if you could drill a small hole in the shutter button, just big enough to insert the Deoxit straw into so you do not have to take it apart everytime. You can cover the hole with a round stickon thing to prevent stuff from getting in there too.

Occasional Contributor
Posts: 12
Registered: ‎11-09-2014

Re: shutter release not working S100

Good to know, I'll keep taking shots w/ mine and give it a few months to see how well the Deoxit (may have) fixed my prob.

Occasional Contributor
Posts: 5
Registered: ‎01-02-2015

Re: shutter release not working S100

I think Canon will ignore the problem and let the consumer suck up the loss. My daughter and I are having the same problem.
Occasional Contributor
Posts: 5
Registered: ‎01-02-2015

Re: shutter release not working S100 [June 30, 2013]

Is there a charge for this? It appears that Canon should be concerned about the number of faulty cameras it sold.
Respected Contributor
Posts: 1,333
Registered: ‎03-01-2014

Re: shutter release not working S100 [June 30, 2013]

Yes there is usually a charge for the repairs unless you are lucky enough to be under warranty. For most the value of the camera is less that the cost of repairs. Canon was selling these for $130 refurbished last week. Auction sites range from about $100 to an insane amount for alleged working models.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement