Canon Community Canon Community
 


Reply
Highlighted
Respected Contributor
Posts: 1,410
Registered: ‎03-01-2014

Re: shutter release not working S100

lol !! I will refrain from all the jokes that come to mind with this fix !!

So glad for all you people you have a cure for it !!

Highlighted
Occasional Contributor
Posts: 5
Registered: ‎10-05-2014

Re: shutter release not working S100

fourteen days and counting since my totally dysfunctional S100 has been up and performing as new. Even so, I will not call the process,(BJ), a FIX! I have, though, taken 614 pictures in that period of time without as much as a hint of the shutter problem. That's good! I'm beginning to rely on the camera. That's bad! It would be helpful if any other photo friends, that dare try this unorthodox method, report their results. (good or bad!)
socaljd
Highlighted
New Contributor
Posts: 4
Registered: ‎12-21-2013

Re: shutter release not working S100

So .. I thought I'd give this a try (nothing to lose eh?) and went to retrieve my S100 from the basement. After taking about 100 pictures the error just isn't there anymore. I wonder if it's the humidity that's actually fixing the problem, as it's quite humid in my basement and the camera has been down there for a few months.

Highlighted
Respected Contributor
Posts: 1,410
Registered: ‎03-01-2014

Re: shutter release not working S100

I think the flexible printed cicuit board that holds the switch buckled perhaps and by blowing into it it has buckled back up again where it's suppose to be. Kind of snapped it back in to place.

Of course anything is possible and if it was hunidity related it will act up again, but I still think it is what I said above or some form of that.

If all you have to do to fix it is blow it and save repair costs then what harm is a blow job fix between camera and owner! lol

What happens in the camera bag stays in the camera bag !! lol

Highlighted
New Contributor
Posts: 3
Registered: ‎10-14-2013

Re: shutter release not working S100

Me too

Highlighted
Frequent Contributor
Posts: 38
Registered: ‎06-13-2014

Re: shutter release not working S100

This is hilarious. Now I have to dig out my camera -in-a-bag. Gave up on it. I will definitely give it a try - nothing to lose -whenI find the camera...
Does anyone have an explanation?
Highlighted
Respected Contributor
Posts: 1,410
Registered: ‎03-01-2014

Re: shutter release not working S100

Angela I gave it my best guess, by blowing hard into those ports it pops the flexible circuit board back into place so that the shutter button can activate the release switch again.

Then theres a humidity guess, introducing the humidity from your breath does something.

 

Highlighted
Frequent Contributor
Posts: 32
Registered: ‎09-16-2014

Re: shutter release not working S100

Hey guys,

Just a quick update. My camera isn't working after a few hours, only until I give it another "huff" then it will start working again. I'm going to get a friend to use some air blower to give it a solid, uh, huff, to see if that's at least any better.

Angela - would be interesting to see what findings you have for your camera!

Highlighted
Frequent Contributor
Posts: 32
Registered: ‎09-16-2014

Re: shutter release not working S100

I LOL-ed so hard at your post. Nice fix name Smiley Happy
Highlighted
Occasional Contributor
Posts: 13
Registered: ‎07-27-2014

Re: shutter release not working S100

My S100 stopped working again. But after a quick puff, it's now operational again. I guess this is one of those "one weird tricks" the interwebs is always talking about

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement