Canon Community Canon Community
 


Reply
Highlighted
New Contributor
Posts: 4
Registered: ‎12-04-2014

plzzz help me guys in powershot SX700 HS

 
Highlighted
VIP
Posts: 13,066
Registered: ‎12-07-2012

Re: plzzz help me guys in powershot SX700 HS

?  What?  Smiley Frustrated

EOS 1DX and 1D Mk IV and several lenses!
Highlighted
New Contributor
Posts: 4
Registered: ‎12-04-2014

Re: plzzz help me guys in powershot SX700 HS

lcd of my camera is not showing any display.what could be the problem plz guide me 

Highlighted
VIP
Posts: 13,066
Registered: ‎12-07-2012

Re: plzzz help me guys in powershot SX700 HS

[ Edited ]

Bad battery or charger. Try a different battery and/or charger.

EOS 1DX and 1D Mk IV and several lenses!
Highlighted
Valued Contributor
Posts: 458
Registered: ‎10-12-2013

Re: plzzz help me guys in powershot SX700 HS

  1. Do you have the camera plugged into a computer when this is occuring? If so, the display will not operate. Unplug the camera.
  2. Are you trying to view the screen in very bright light? Does it work indoors?
  3. Has the camera been dropped at all? A ribbon cable may have come loose.
  4. Have you turned off the image display so it won't show your images? See page 51 in the user manual.

 

Steve M.

Highlighted
Respected Contributor
Posts: 1,410
Registered: ‎03-01-2014

Re: plzzz help me guys in powershot SX700 HS

How about some more info,

Can you see your menus ? If you can you might have turned your display off for viewing after shots ? 

If you can see your menus you can do a "reset all" to put everything back to defaults.

If you can't see the menus or images and you have power to it then your camera is broke and will need service.

 

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement