Canon Community Canon Community
 


Reply
Highlighted
New Contributor
Posts: 4
Registered: ‎01-23-2019

Sx530 HS stuck in low shutter speeds

Hi there I’m hoping someone can help me , I have a canon sx530hs that no matter what setting I have it in it keeps selecting very low shutter speeds , even in auto setting. Can anyone advise how to fix the problem.
Thanks
Jon
Respected Contributor
Posts: 1,229
Registered: ‎03-01-2014

Re: Sx530 HS stuck in low shutter speeds

Try doing a reset to defaults thru your settings menu in case some setting is the cause

Reputable Contributor
Posts: 679
Registered: ‎12-24-2013

Re: Sx530 HS stuck in low shutter speeds

Are the photos overexposed due to slow shutter speeds?  

 

Have you tried manual mode? 

Mike Sowsun
S110, SL1, 80D, 5D Mk III
New Contributor
Posts: 4
Registered: ‎01-23-2019

Re: Sx530 HS stuck in low shutter speeds

Hi Mike , yes ive tried manual mode and it still keeps selecting a differant low shutter speed.

Cheers

Jon

New Contributor
Posts: 4
Registered: ‎01-23-2019

Re: Sx530 HS stuck in low shutter speeds

Tried that John thanks mate but still selecting a random low shutter speed

Reputable Contributor
Posts: 679
Registered: ‎12-24-2013

Re: Sx530 HS stuck in low shutter speeds

[ Edited ]

Are some of the photos overexposed due to slow shutter speeds? 

Mike Sowsun
S110, SL1, 80D, 5D Mk III
New Contributor
Posts: 4
Registered: ‎01-23-2019

Re: Sx530 HS stuck in low shutter speeds

They are Mike

Reputable Contributor
Posts: 679
Registered: ‎12-24-2013

Re: Sx530 HS stuck in low shutter speeds

[ Edited ]

Well, it looks like a serious malfunction that would need a visit to a repair facility. 

 

Is it still on warranty? If not, the repair cost might be more than a replacement cost.

Mike Sowsun
S110, SL1, 80D, 5D Mk III
Respected Contributor
Posts: 1,229
Registered: ‎03-01-2014

Re: Sx530 HS stuck in low shutter speeds

It most likely will cost more to repair it, used $150, new $250 on Amazon

Product Expert
Posts: 967
Registered: ‎10-16-2012

Re: Sx530 HS stuck in low shutter speeds

Hi Jonboy71,

 

Thanks for posting.

 

Please set your camera to it's Tv (Time value- AKA Shutter priority) mode, then select a high shutter speed (e.g. 1/500 or 1/1000 second). For information about this mode, please click here.

 

Does your camera use a different shutter speed than the one you set?

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement