Canon Community Canon Community
 


Reply
New Contributor
Posts: 2
Registered: ‎04-28-2020

SX60HS

I haven't used my camera in a while. The camera is 6 years old but last used it in February.  I brought it out a few days ago and it worked fine then today I shot some pictures and I get the error "unidentified image"  any suggestions. I've turned it off and on, changed the battery.

Respected Contributor
Posts: 1,459
Registered: ‎03-01-2014

Re: SX60HS

Try a different full-sized SD card,( not one of those micro SD's in an adapter). You can also try reformatting your current SD card if you do not have another full size one and also do a reset to defaults thru the settings menu

New Contributor
Posts: 2
Registered: ‎04-28-2020

Re: SX60HS

Thank you I will try that.  Have to get another card.

Respected Contributor
Posts: 1,076
Registered: ‎10-17-2012

Re: SX60HS

hello vetchr, 

I understand you are seeking support for your PowerShot SX60 HS. At this time we do not have electronic support avialable for this equipment.  We regret any inconvenience that this may cause you. 

For support on this product, please call 1-800-652-2666 and follow the prompts for Technical Support. Agents are available during the following times. All times EST, excluding holidays.


Cameras - PowerShot -- 1-800-652-2666 Monday-Friday: 9:00 am to 9:00 pm

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement