Canon Community Canon Community
 


Reply
Occasional Contributor
Posts: 8
Registered: ‎07-08-2019
Accepted Solution

SX60 turns itself on and sticks at "busy" screen

SX60 turns itself on then sticks at either the busy screen, or if I remove the sd card then the "no memory card" screen.

Occasional Contributor
Posts: 8
Registered: ‎07-08-2019

Re: SX60 turns itself on and sticks at "busy" screen

I have just found a workaround: hitting the record button gets it running normally.  But it still instantly turns back on when powered off and boots to the same busy or no memory card screen.

Respected Contributor
Posts: 1,298
Registered: ‎03-01-2014

Re: SX60 turns itself on and sticks at "busy" screen

Have you tried it without the SD card inserted? You may have a bad card.

Occasional Contributor
Posts: 8
Registered: ‎07-08-2019

Re: SX60 turns itself on and sticks at "busy" screen

Yes, that is the second case where it stays at the "no memory card" screen.

Occasional Contributor
Posts: 8
Registered: ‎07-08-2019

Re: SX60 turns itself on and sticks at "busy" screen

I think the card is good because it was happy to do a factory reset, and it takes photos fine.  But the factory reset didn't help the problem of it turning itself on and sticking at either the busy screen or the no memory card screen.

Respected Contributor
Posts: 1,298
Registered: ‎03-01-2014

Re: SX60 turns itself on and sticks at "busy" screen

I have the SX50 and if it was doing what yours is doing and it is not the card I would drop a couple of drops of Deoxit5 into the seam around the power button. It will not harm anything plastic or rubber and will help if there is any dirt, oxidation or the PC board switch underneath the mechanical button is stuck in a semi on/off position. That mechanical button presses down on another switch mounted on what is called a flexible PC board. Deoxit5 is sold in a small tube or a spray can with an adjustable spray rate, Low, Med or High. It is a high quality, safe electronics cleaner I've used it for over a decade, it always comes in handy even if it does not solve your issue.

In the meantime, someone else might chime in with a different idea to try.

Occasional Contributor
Posts: 8
Registered: ‎07-08-2019

Re: SX60 turns itself on and sticks at "busy" screen

Thanks John, I will try that.

Respected Contributor
Posts: 1,298
Registered: ‎03-01-2014

Re: SX60 turns itself on and sticks at "busy" screen

You're welcome, best of luck to you!

Occasional Contributor
Posts: 8
Registered: ‎07-08-2019

Re: SX60 turns itself on and sticks at "busy" screen

As the camera is second hand and outside guarantee (so I have nothing really to lose), I opened it up (taking appropriate anti-static precautions) and carefully disconnected the ribbon cable that connects the switch to the motherboard.  It still switches itself on even when the switch assembly is disconnected, so I don't think the switch can be causing this. 

 

I will still give the cleaning idea a try as it couldn't do any harm.

Respected Contributor
Posts: 1,298
Registered: ‎03-01-2014

Re: SX60 turns itself on and sticks at "busy" screen

wow! Did you check if Canon had any firmware updates? That motherboard is getting a false signal to turn on from somewhere, maybe some dirt or something has created a short. I'd find it really odd if the firmware was corrupt and doing this but I suppose it is possible. I don't think the camera communicates with the battery when it is off, I was thinking that somehow the battery might do this? Very odd, Calling an exorcist might be an option!

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement