Canon Community Canon Community
 


Reply
Highlighted
New Contributor
Posts: 1
Registered: ‎06-01-2019

SD1200 IS camera not recognized

I use two Canon cameras in a Windows 10 environment: myPowerShot 520 HS works fine, but my computer stopped recognizing my SD1200 IS camera today.

 

When I connect the SD1200 camera and turn it on, the camera displays a "Communication Failure". The computer displays nothing.

 

When I connect the 520 and turn it on (same cable, same port), the computer recognizes that a camera is connected and allows me to upload my photographs.

 

I have reinstalled and updated my drivers, but the problem continues. Any suggestions?

Highlighted
VIP
Posts: 10,711
Registered: ‎08-13-2015

Re: SD1200 IS camera not recognized

Try a different USB port.  One of the USB ports on my laptop has recently decided that it does not like one of my cameras.

----------------------------------------------------------------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."
Highlighted
New Contributor
Posts: 1
Registered: ‎10-07-2020

Re: SD1200 IS camera not recognized

I have the same problem.  I downloaded and installed the software just given to me (Oct. 7, 2020) and tried everything I could think of including rebooting, changing usb input, and searching for new device. Nothing works so far.  Cheers, Don.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement