Canon Community Canon Community
 


Reply
Occasional Contributor
Posts: 6
Registered: ‎11-24-2013

S110 on/off switch

Got two of these for Christmas 2013.  One had problems after a few weeks of light use.  Push the on button and nothing happens.  I know the battery was fully charged.  Changed to a new fully charged battery.  Same problem.  Send it in for repair.  After a short while, not un reasonable, it was returned working properly.  About two months later, the same problem pops up again.  Called the service center. Their record showed the previous mailing.  The technician said that it had been replaced.  It was obviously repaired.  Same serials number and packaging.  Loop cord still attached.  None less, I demanded an new one.  

 

I give Canon credit I received a call from their cooperage office saying that a new on would be sent by overnight mail.  It was srecieved when stated.  Thank you Canon. 

 

I wonder if anyone else had this problem,  

 

Larry Jay

Respected Contributor
Posts: 1,459
Registered: ‎03-01-2014

Re: S110 on/off switch

I do not have that camera but that same exact symptom has been reported with the s100 model. If I were you, and if possible I would invest in an extended warranty from a good company like Square Trade.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement