Canon Community Canon Community
 


Reply
New Contributor
Posts: 3
Registered: ‎04-27-2020

Rarely used G12 Screen Problem when shooting and displaying photos NOT menu

Thanks to anyone able to help.  I hardly ever use my G12 but took it out again last week.  It worked well, I shot video, uploaded to computer, I put camera away  safely, etc.  Today I took out the camera again and tried to shoot but the display after the menu is construed in violet hues.  This isn't an LCD screen issue because the start up screen and menus appear normal.  And when I point and shoot using the view finder, the photo displays as similarly distorted.  I have tried to AF-assist beam toggle to ON and OFF.  No change.  Tried resetting the settings completely: same.  Tried LCD brightness adjustment: same.  Any other tips? I really doubt this is an issue with a wire or dropping the camera unless a ghost lives here and drops my camera  when I am not around. Thanks again.

VIP
Posts: 11,807
Registered: ‎08-13-2015

Re: Rarely used G12 Screen Problem when shooting and displaying photos NOT menu

How much video did you shoot?  

 

If you are saying that all of your still images now have a severe tint to them, then your image sensor may be bad.  Can you post a sample image of the problem.

----------------------------------------------------------------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."
New Contributor
Posts: 3
Registered: ‎04-27-2020

Re: Rarely used G12 Screen Problem when shooting and displaying photos NOT menu

Since the video was uploaded to my computer, I deleted it on the camera last week.  No issue at that time.  Today, I took these images of my camera screen with my cell phone's camera.  First purple one is what my camera sees.  Second with the white stripe to the left is the image it displays when I use the flash to take a picture.  20200427_165209.jpg20200427_165209.jpg

VIP
Posts: 11,807
Registered: ‎08-13-2015

Re: Rarely used G12 Screen Problem when shooting and displaying photos NOT menu

Sadly, that looks like a failing image sensor.  It is possible that it overheated, and was not able to completely cool without damaging itself.  Whatever the cause, "He' dead, Jim."

----------------------------------------------------------------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."
New Contributor
Posts: 3
Registered: ‎04-27-2020

Re: Rarely used G12 Screen Problem when shooting and displaying photos NOT menu

Oh, how sad.  Ok, well, since this looks like it would most likely be headed for the garbage, I'd be down to replace the image sensor myself since I'm a bit handy and a former USMC electrician plus a wrencher on my mcycles.  Is it possible that Canon supplies image sensors for replacement? Thanks again so much.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement