Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎04-08-2016

Powershot SX60 HS won't turn on

Someone please please help.
Canon powershot sx60 HS.

When I press the power button the camera will beep and the lens will go out about half the normal "turn-on" length. It will also beep when I press the display and wifi connect buttons and the screen will do a tiny flash like it's trying to do something but nothing will happen. 
It will also go back to completly off, but nothing changes. I only have one battery, and the charging module says it's "full". I got this camera a month ago, but I'm in Argentina right now, not at home where I got it. It hasn't been dropped or seriously dropped. I just need it to work again.

New Contributor
Posts: 2
Registered: ‎12-30-2016

Re: Powershot SX60 HS won't turn on

I have a similar problem, only in my case the camera will not power on at all. My battery is good as it powers another camera without any problem. The on off button feels fine though that could be deceptive.

I am reluctant to take it apart if there is a chance of a "quick fix" so does anyone have any ideas please?

VIP
Posts: 8,046
Registered: ‎08-13-2015

Re: Powershot SX60 HS won't turn on

The battery compartment door should have a micro-switch to detect when the door is open or closed.  If the camera thinks the door is open, then it will not power up.  The same might be true of the memory card slot, too.  Make sure both doors are securely closed, and not forced closed.

 

Still no joy, after checking the compartment doors.  Contact Canon U.S. Support.  Your camera may need service. 

----------------------------------------------------------------------------------------------------------------------------------------------------------

"I don't rent software. I use Photoshop CS6, ACR 9.8 and Lightroom 6.8 ."
New Contributor
Posts: 2
Registered: ‎12-30-2016

Re: Powershot SX60 HS won't turn on

Hi, thanks for coming back, are you sure this model has a battery compartment microswitch? If you are, could you give me some guidance as to where it is located because I cannot find it. Thanks
Highlighted
VIP
Posts: 8,046
Registered: ‎08-13-2015

Re: Powershot SX60 HS won't turn on


@berniethebolt wrote:
Hi, thanks for coming back, are you sure this model has a battery compartment microswitch? If you are, could you give me some guidance as to where it is located because I cannot find it. Thanks

I do not own that model camera, so I do not know where a switch would be located, or if one is present.  Just make sure that the doors are properly closed, nice and tight.

 

You might also want to take peek inside of the battery compartment, and make sure that there are no foreign objects or bent pins.  Again, I suggest that you call Canon U.S. Support for the best advice on what to do.

----------------------------------------------------------------------------------------------------------------------------------------------------------

"I don't rent software. I use Photoshop CS6, ACR 9.8 and Lightroom 6.8 ."
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement