Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎05-02-2020

Powershot SX540HS & Image Canon, Refuses to let me Log into Site

Powershot SX540HS 4 Years old Trying to even Sign into 'Image Canon' has turned into a nightmare. No matter what I do, it refuses to let me sign in & I have tried everything possible!!

I have clicked through all 3 documents diplayed as part of the user agreement & the 'I agree' option is constantly Greyed Out leaving no other option but to click on but 'I Disagree', this then takes me to the Image Canon Web Page and i get the Sign in Options list, Google is my chosen verification for my Canon ID sign in & when i click this & sign in I am taken straight back to the User Agreement.

I have also tried to sign in with my Canon ID e-mail & password but still sent back to the User agreement & I am right back to square one!!! Just Running in circles!!

Antone know a solution to this

Product Expert
Posts: 313
Registered: ‎07-03-2019

Re: Powershot SX540HS & Image Canon, Refuses to let me Log into Site

Hi Digidoc,

 

The first thing I would check is that you can use your Canon account email and password to login to your Canon account on www.usa.canon.com just to make sure the login information is correct. If the password you remember does not work on www.usa.canon.com you may have to reset your password and then try to use the new password on image.canon.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement