Canon Community Canon Community
 


Reply
New Contributor
Posts: 2
Registered: ‎12-04-2015
Accepted Solution

Powershot SX160 Date/Time Menu Resets to Zero

The date and time menu constantly resets itself to zero.   I have to input the correct values several times a day.  Is there a fix for this??

Respected Contributor
Posts: 1,457
Registered: ‎03-01-2014

Re: Powershot SX160 Date/Time Menu Resets to Zero

Thats an easy fix your date and time battery is most likely dead and needs to be replaced it is a CR1220

 

Date n Time.JPG

 

New Contributor
Posts: 2
Registered: ‎12-04-2015

Re: Powershot SX160 Date/Time Menu Resets to Zero

I have 3 of these models - I should have known about the battery. Thanks.
Respected Contributor
Posts: 1,457
Registered: ‎03-01-2014

Re: Powershot SX160 Date/Time Menu Resets to Zero

Your quite welcome I forget the silliest things also from time to time too lol

New Contributor
Posts: 2
Registered: ‎02-01-2018

Re: Powershot SX160 Date/Time Menu Resets to Zero

Hi,

 

It is now Feb. 2018.  I have the same problem.  I bought a new battery.  It still does not work.  The date again reset to zero when I powered off.  Any help would be very much appreciated.

 

Thanks.

Reputable Contributor
Posts: 593
Registered: ‎11-20-2012

Re: Powershot SX160 Date/Time Menu Resets to Zero

Hi ML2018! 

Thanks for joining and posting in the Canon Forums! 

The Forum is not intended for immediate help, but a place to allow for the Community to give you assistance and feedback.

If you are in the United States and this is an urgent support need, please CLICK HERE to reach our friendly Technical Support Team. 

If you live outside the United States, please click here and select your country or region for your support needs.

We hope this helps! 

Respected Contributor
Posts: 1,457
Registered: ‎03-01-2014

Re: Powershot SX160 Date/Time Menu Resets to Zero

Well lets just hope you got a bad brand new CR1220 battery because that is what maintains the date/time you set. I would try another battery and make sure it is in there correctly although I dont think it will fit if the battery isnt in the right way. Also look inside the battery compartment with a flashlight for any signs of a problem of debri in there. I got my fingers crossed it was just a bad battery

New Contributor
Posts: 2
Registered: ‎02-01-2018

Re: Powershot SX160 Date/Time Menu Resets to Zero

Hi,

 

Thanks for the reply.  By luck I solved the problem.  I suspected that it was a contact problem.  The bits of metal in the small cavity were very flimsy.  I tried adding a small piece of aluminum foil on the side with a bit of tail haning outside (so it won't fall in) and inserted the battery again.  It is now working well.  This means that the contact point for the battery on the side is not tight enough.

 

The reason I suspected the contact problem because it was also the contact problem for the CR1220 cavity in one of my older canon cameras a few years ago.

Respected Contributor
Posts: 1,457
Registered: ‎03-01-2014

Re: Powershot SX160 Date/Time Menu Resets to Zero

Excellent detective work!

New Contributor
Posts: 1
Registered: ‎08-07-2020

Re: Powershot SX160 Date/Time Menu Resets to Zero

I have an SX 120 IS and have the sanme problem. As I cannot find anything under SX 120 in the Community, the manual for the 120 says it, the Date/Time battery lasts approximately 7 years and the replacement is a CR 1220 - is this still correct?

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement