Canon Community Canon Community

New Contributor
Posts: 1
Registered: ‎04-06-2018

Powershot A3400 IS: unable to detect camera

For some strange reason, I can no longer upload my photos. The screen for transferring photos does not appear. I tried to connect to the camera through the image browser, but it says it cannot detect the camera.  I downloaded the updated image browser but that did not help.


I am using the same USB cord and port that I always have, and which worked as recently as two weeks ago. When I plug the camera in, then plug it into the USB port, it does not show as a drive on Windows Explorer.


On my old desktop which runs Vista, I put in the software disk but when I run it I get: D:\software\install\UniversalInstaller.exe "not a valid Win32 application". (The desktop is 64 bit)

On a laptop with Win7, when I try to run the software I get:  D:\software\install\UniversalInstaller.exe "Error performing inpage operation."


Any suggestions?

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement