Canon Community Canon Community
 


Reply
Highlighted
New Contributor
Posts: 1
Registered: ‎06-24-2015

PowerShot S110 Stuck Pixel on LCD or Lens?

I picked up a refurbished S110 from the Canon online store a few weeks ago and recently I noticed a discolored pixel on the LCD. This pixel is always brighter than the rest of the screen and usually appears most apparent when the lens is zoomed in and the scene is dark.

 

The pixel will change positions as I zoom in on the lens, becoming larger as the lens zooms in and smaller when the lens zooms out. I thought it would be a stuck pixel on the LCD but the stuck pixel moves position on the screen as the lens zooms. Therefore I thought it was an issue with the lens, but the stuck pixel doesn't seem to appear in the photos I take even as the stuck appears on the LCD.

 

The stuck pixel only appears when the I'm setting up to take a picture, it doesn't even appear in the photo preview that shows up after you have taken the photo. What's going on and should I consider calling Canon to get this serviced?

 

See examples of the issue below:

 

Stuck Pixel on the LCD before taking photo (it's on the right side)

 

Example 2 (appears on the bottom right, image is cropped)

 

Final photo of scene (stuck pixel doesn't appear)

Highlighted
Super Contributor
Posts: 140
Registered: ‎05-24-2013

Re: PowerShot S110 Stuck Pixel on LCD or Lens?

This could be on the CCD, or should I say sensor or it may be on the LCD - does it appear on print? If so, then it's just got to be the CCD sensor.

 

See this article it may or may not help.

 

Dave

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement