Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎11-24-2012

I have problems with the white balance on my PowerShot SX20. Constant yellow cast.

I am unable to get a decent white balance on my PowerShot SX20. I would like to be able to shoot many shots without readjusting the white balance. Even looking thru the view finder there is a yellow cast. I am photographing artwork using no flash and a light box and have to EXTENSIVELY PhotoShop to try to get back to original tones. Using identical set up, lighting and subject and reshooting with a much less expensive, "inferior" camera, there is no yellow cast. I have followed the on line instructions for white balance on this model and it makes no difference.

Highlighted
Occasional Contributor
Posts: 7
Registered: ‎11-24-2012

Re: I have problems with the white balance on my Overshot SX20. Constant yellow cast.

I DON'T KNOW THIS MODEL BUT DOES IT HAVE EFFECTS ON IT.  II FILTERS OR ABILITY TO CHANGE FROM COLOR TO BLACK AND WHITE THAT KIND OF THING.  I HAVE GOTTEN SOME PROBLEMS BECAUSE SOMEONE IN MY FAMILY PLAYED WITH THINGS ON MY CAMERA THAT I NEVER TOUCHED. IT GAVE ME FITS BEFORE I FOUND OUT WHAT WAS SUDDENLY WRONG.  CHECK YOUR ENTIRE SET UP OVER AND RESET YOUR MENU.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement