Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎12-03-2012

I have a Power Shot SD4500 IS and after battery is fully charged battery runs down without any use.

I have a Power Shot SD4500 IS and after charging battery  then placing in camera and within a day the battery is dead.  I have tried replacing with a new battery and have the same problem.  Any suggestions?

The last time (2 years ago) I had a problem with my previous ELPH I was told it was less expensive to replace the camera than to repair, but after buying 2 in 5 years with limited use, this is getting old.

 

HELP

jfo
Super Contributor
Posts: 280
Registered: ‎11-12-2012

Re: I have a Power Shot SD4500 IS and after battery is fully charged battery runs down without any u

Welcome!

 

This might be an obvious question, but just to double-check, are you turning the camera off when you are not using it? 

 

Is the camera working properly when the battery is charged?  Is the new one you bought an authentic Canon one? (sometimes generics have a lower capacity or are more prone to problems).

Highlighted
Respected Contributor
Posts: 1,005
Registered: ‎10-23-2012

Re: I have a Power Shot SD4500 IS and after battery is fully charged battery runs down without any u

Pharmboy007,

 

I would like to ask a couple questions to see if I can determine what is causing the issue.

 

  1. How long is the camera sitting before you are using it and finding out that the battery is no longer charged?
  2. Does this happen with other batteries, or just the one battery?

If this is a time sensitive-matter, additional support options are available at Contact Us.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement