Canon Community Canon Community
 


Reply
Highlighted
New Contributor
Posts: 1
Registered: ‎03-11-2016

I have a G15 camera. The mode dial does not correspond to the monitor screen, in some instances.

For example P on the mode dial shows M on the screen, TV is Auto, AV is auto, M is C1. The rest are Ok.

I could use C1 and C2 to ape P and TV. Is this a software/firmware problem?

Highlighted
VIP
Posts: 9,078
Registered: ‎08-13-2015

Re: I have a G15 camera. The mode dial does not correspond to the monitor screen, in some instances.

You should probably contact Canon Service.  It sounds like your camera is either malfunctioning, or that the label plate on your mode dial switch has come loose, and has rotated into an incorrect position.  In the case of the latter, the plate is likely about to fall off and get lost.

----------------------------------------------------------------------------------------------------------------------------------------------------------

"Doctor told me to get out and walk, so I bought a Canon."
Highlighted
Honored Contributor
Posts: 6,257
Registered: ‎11-13-2012

Re: I have a G15 camera. The mode dial does not correspond to the monitor screen, in some instances.

Since the problem doesn't seem like a simple offset (i.e. each setting off by one on the dial) it could be an electronic problem in the camera. If you tried restting all functions (pg 231 of manual) and that didn't correct problem it sounds like service is required.

John Hoffman
Conway, NH

1D X, Rebel T5i, Many lenses, Pixma PRO-100, MX472, LR Classic
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement