Canon Community Canon Community
 


Reply
Occasional Contributor
Posts: 5
Registered: ‎01-02-2015

I am having problems with my Canon S100 camera. The shutter is not working correctly.

I hope this is the right place to post a complaint about my Canon S100 camera's shutter not working correctly.  My daughter purchased two of these cameras, one for me, and one for herself.  Both cameras are having the same problem.  I hope Canon can help us with this serious problem.  What good is a camera if it does not take pictures?

Respected Contributor
Posts: 1,298
Registered: ‎03-01-2014

Re: I am having problems with my Canon S100 camera. The shutter is not working correctly.

 If you can return the cameras do it now. Unfortunately those models have a history of having a shutter release button problem. There is another thread here for that specific problem and it is the longest thread in the Poershot forum.

That thread is here:

http://community.usa.canon.com/t5/PowerShot/shutter-release-not-working-S100/m-p/129427#M6446

 

 

Frequent Contributor
Posts: 38
Registered: ‎06-13-2014

Re: I am having problems with my Canon S100 camera. The shutter is not working correctly.

Hi thomross
Do you have the series numbers handy for your two S100s?
At this point I am just collecting info to get it out there.

Moderator
Posts: 1,389
Registered: ‎10-25-2012

Re: I am having problems with my Canon S100 camera. The shutter is not working correctly.

AngelaX,

 

Posting serial numbers or any personal/identifiable information in the forum is considered a violation of the FORUM GUIDELINES, and will be removed. 

If you are still having issues with your PowerShot S100, we ask that you contact Canon in Canada to resolve your issues.

 

thromross,

We ask that you please contact our technical support team here in the US for your PowerShot S100, so that we can take a look at your situation. They're available by phone or email by clicking HERE.

 

Thanks and have a great day!

Highlighted
Frequent Contributor
Posts: 38
Registered: ‎06-13-2014

Re: I am having problems with my Canon S100 camera. The shutter is not working correctly.


My apologies.
Frequent Contributor
Posts: 38
Registered: ‎06-13-2014

Re: I am having problems with my Canon S100 camera. The shutter is not working correctly.

Correction. Sorry thomrose
Please post the first two digits of the series number, such as 41 or 42 or 46, NOT the whole serial number, which would be traceable personal information, as pointed out by Stephen, the moderator.
My apologies for any confusion.
Occasional Contributor
Posts: 5
Registered: ‎11-16-2014

Re: I am having problems with my Canon S100 camera. The shutter is not working correctly.

Stephen (Canon),

I find it quite surprising that you do not respond to 28 pages of comments regarding this issue on the other thread and yet you directly comment here.

 

Seems to me that the problem arises after significant use as the contacts in the shutter switch corrode and do not get the contact that they once did.  With many users this occurs just outside the 1yr warranty. However, it is clear that this is a design fault as opposed to natural 'wear and tear' and therefore I would expect that a company with Canon's reputation for excellent service would offer free repairs.

 

Can you please confirm if Canon are preparing a response on this issue?

 

Regards,

Neil Walker

Frequent Contributor
Posts: 38
Registered: ‎06-13-2014

Re: I am having problems with my Canon S100 camera. The shutter is not working correctly.

Yes. As the many other members of the S100 shutter release problem family, I am still having a problem. Our local Canon Canada has a B- rating, but more official complaints to come. Two different service reps told me over the phone that they knew of no problem with the shutter release function.
Canon USA has an incomplete list of series numbers that have the issue, and these are the only ones on official recall. This is the reason for my request for the first two digits. It seams all the old references to series, those with only non-traceable two digit indicators, have disappeared.
Is this removal adhering to Forum guidelines?
In good faith, A
Occasional Contributor
Posts: 5
Registered: ‎01-02-2015

Re: I am having problems with my Canon S100 camera. The shutter is not working correctly.

Stephen, I need your help with this camera.  I called Canon customer service, but was not provided any resolution.  Any suggestions on how to remedy this problem with the S100 without sending, for a fee, to Newport News, VA will be greatly appeciated.

Moderator
Posts: 1,627
Registered: ‎07-08-2013

Re: I am having problems with my Canon S100 camera. The shutter is not working correctly.

Hi, thomross!

 

You can see the details on the product advisory for the PowerShot S100, including the serial number range of potentially affected cameras, by clicking here.  If you need any assistance with the issue addressed in the service advisory, or if you have any other concerns about your camera, we recommend contacting our technical support team, whose contact information you'll find by clicking here.

 

We hope this helps!

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement