Canon Community Canon Community
 


Reply
Highlighted
New Contributor
Posts: 1
Registered: ‎08-03-2014

ELPH 330 battery problem

My battery will not charge. I've tried to charge it several times, the charger turns green, but when I put the camera back into the camera it tells me to recharge the battery. Is the battery covered under warranty? The camera was purchased from Amazon in January 2014.
Highlighted
Respected Contributor
Posts: 1,381
Registered: ‎03-01-2014

Re: ELPH 330 battery problem

Amazon does not warranty it beyond maybe 30 days, you have to go to the manufacturers website ( is it a Cnon Battery? ) and check their policy. The warranty is usually for one year so you may be in luck and you can get the receipt, if youn dont have it, from your Amazon account.

Have you checked the battery for physical damage, swelling broken contacts etc.? That would not be covered and you will have to pay shipping costs regardless.

Have you looked inside the battery compartment for damage or corrosion?

And finally does the battery does close properly...these are all things to look at.

Highlighted
New Contributor
Posts: 2
Registered: ‎12-01-2014

Re: ELPH 330 battery problem

My camera is doing the same thing after owning it for 11 months.  This morning, I found a service advisory that says Canon is aware of the problem and to contact customer service.  I plan to do this when they open at 10am.  I hope this is helpful. 

Here is the link:  http://www.usa.canon.com/cusa/consumer/products/cameras/slr_cameras?pageKeyCode=prdAdvDetail&docId=0...

Highlighted
New Contributor
Posts: 2
Registered: ‎12-01-2014

Re: ELPH 330 battery problem

I called Canon customer support and after getting some pertinent info, they emailed me an address to ship the camera to for repair.  They are also going to email me mailing labels for free shipping of the camera.  The rep was very courteous and apologized for the problem.  

Highlighted
Occasional Contributor
Posts: 6
Registered: ‎09-29-2018

Re: ELPH 330 battery problem


@marcia_m_young wrote:

My camera is doing the same thing after owning it for 11 months.  This morning, I found a service advisory that says Canon is aware of the problem and to contact customer service.  I plan to do this when they open at 10am.  I hope this is helpful. 

Here is the link:  http://www.usa.canon.com/cusa/consumer/products/cameras/slr_cameras?pageKeyCode=prdAdvDetail&docId=0...


Is there an updated link, this one isn't working. I think my camera has the same problem.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement