Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎08-25-2014

ELPH 310 HS - Spots on lens showing up on pictures?

Hi - I've noticed that if I take a picture with a lighter solid background, I see these grey-ish spots on the final image.

 

I've cleaned the outermost lens (inside/outside) ... but with that piece off, I can still see the 'spots' in the viewfinder - so the issue must be at a different spot.  They are less prevelent when zoomed out ... but get more obvious when zoomed in.

 

I've attached images of what this is like - has anyone encountered this or know of a DIY way to clean the part that is creating these spots?

 

Thanks for the help!

 

Image 1 - The part I removed ... spots still in viewfinder without this piece

Image 2 - example of photo taken (zoomed in) that has the spots

Image 3 - with the part I removed off, I zoomed in on a white piece of paper - to show the spots more easily

 

parts.jpg

 

real photo.JPG

 

removed - zoomed.jpg

Super Contributor
Posts: 140
Registered: ‎05-24-2013

Re: ELPH 310 HS - Spots on lens showing up on pictures?

Looks like dust on one of the inner lenses or on the sensor, looks like this will have to go in for service as stripping the lens assembley down is not an easy task.

 

Dave

Respected Contributor
Posts: 1,005
Registered: ‎10-23-2012

Re: ELPH 310 HS - Spots on lens showing up on pictures?

Hi btappan!

 

Thank you for posting.

 

I am inclined to agree with Davy on this one.  These spots look like they are caused by dust or debris on the inside of the camera, possibly on the image sensor.  The camera will need to be cleaned by our Factory Service Center.  To start this process, you'll need to complete a Repair Request on our website.

 

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
New Contributor
Posts: 2
Registered: ‎05-18-2015

Re: ELPH 310 HS - Spots on lens showing up on pictures?

I know this thread is a little old, but I just had this happen to me as well, and I got lucky with a last-resort solution that SOLVED the issue. It's basically vacuuming it out as described many times on the internet. I've provided one of the links here... http://www.wikihow.com/Clean-Digital-Camera-Lens-with-a-Vacuum-Cleaner

I'd guess the Canon techs would shudder at this, but if you've already decided to just get a new camera, it's worth a try.

Occasional Contributor
Posts: 5
Registered: ‎10-22-2016

Re: ELPH 310 HS - Spots on lens showing up on pictures?

OMG you saved the day!  Your vacuum cleaner trick absolutely saved my Elph 310 HS.   I had nothing to lose since the spots were so bad.  Now they're gone at even the tightest zoom.  Thank you thank you thank you!

New Contributor
Posts: 2
Registered: ‎05-18-2015

Re: ELPH 310 HS - Spots on lens showing up on pictures?

Dear kupe,

 

No problem!  Glad I could help pass on this neat little "fix" by someone else who took the risk to figure it out. Feels great, doesn't it Smiley Very Happy !!!

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement