Canon Community Canon Community
 


Reply
Highlighted
Occasional Contributor
Posts: 9
Registered: ‎01-07-2019

Does the Powershot SX70 have a Focus/Shutter Defect?

[ Edited ]

I had a shutter/focus problem with my new SX70 which I thought was due to a defective camera, but after reading a recent review, I am convinced that some (or maybe all?) SX70s may have this same problem. 

 

After I would pre-focus ("beep" and green rectangle confirming it was ready to shoot) and then fully press the shutter release button, the camera would either hesitate or refocus. I didn’t notice it much at first when photographing still subjects but it was so frustrating with birds who move around. I have the SX60 and compared them by setting both cameras to Default and Auto (apples to apples!) and tried both side by side. The SX60 was definitely faster. Then I set both cameras to Program Mode (P) with Spot Focus and tried a few different subjects with the same result; the SX70 would usually hesitate after pressing the button all the way down, and the SX60 behaved as it should and released the shutter as soon as the button was fully pressed.

 

I called Canon Tech Support who said it sounded like a shutter defect and to send it back. 

————————

Here is a paragraph from an independant review I found online that described the exact problem I experienced:

 

Focusing -  

Using auto-focus, if you tend to pre-focus your shots (by half-pressing the shutter release button), and then fully pressing the shutter release button, the camera has an annoying habit of refocusing for you, after you've fully pressed the shutter release button. This appeared to be an intermittent issue, and would randomly happen some of the time, but not others. Other people in the office who tested the camera found the same issue. 

————————

Sadly, although I loved the SX70’s remarkable image quality and better button placement (along with many impressive new features I didn't have time to explore) I returned it for a refund instead of gambling on a replacement. I hope Canon will fix this issue, because I was so impressed with the SX70 otherwise and would definitely give it a try again if that issue was fixed. I plan to wait about 6 months or so, to read more feedback and reviews on this camera before reconsidering.

:-(

 

Below is the first photo I took with the SX70:

canon_sx70_pointsettia.jpg

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement