Canon Community Canon Community

New Contributor
Posts: 1
Registered: ‎01-22-2014

Does anyone else have problems with verbatim sdhc memory cards?

I was asked to find out why the cameras/cards don't work.  If I monkey around with the sdhc card, taking it in and out, and turning the camera on and off, it works sometimes.  What do I need to do?  Also, when I first tried to format the card, format was ghosted in the menu until I called support and then it worked. and then it didn't.

Super Contributor
Posts: 140
Registered: ‎05-24-2013

Re: Does anyone else have problems with verbatim sdhc memory cards?

[ Edited ]

Do ensure the card isn't locked or the slider on the side isn't 'stuck halfway', try flicking it a couple of times. Then with a non fluff-free cloth gently wipe the gold contact strips...  all you can do is try again ensuring that you format it first.


If this doesn't work then the only option is to try another card.  You really don't wanna be turning things OFF and ON to get them to work. 


Should it be a new card then see if you can exchange it, some case you *may* have to send it back to the manufacturer.


It could be the camera, there's only one way to find out and that is by trying another card... even a borrowed one. Just thought of another option..... try it on a card reader, some computers have them and some don't, in this case you use an external card reader



powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement