Canon Community Canon Community
 


Reply
New Contributor
Posts: 2
Registered: ‎12-03-2013

Device not found - connecting Powershot Elph 330HS to Canon MX892

Hello,

 

I just received an Elph 330HS today.  I've had my Canon MX892 printer for a while.  It's connected to my wireless network and works fine.

 

I'm trying to connect the camera to the printer.  I turned my printer on (and verified that it shows up as a client on my wireless network).  On the camera I selected the printer icon, entered in all my wireless settings (and verified the camera's MAC address shows up as a client on my wireless network), selected "Add device" and waited.  Finally I get the error "Connection error - Device not found".

 

I followed the instructions in the manual.  I do not want to use the camera as an access point.

 

What else do I have to do?

New Contributor
Posts: 2
Registered: ‎12-03-2013

Re: Device not found - connecting Powershot Elph 330HS to Canon MX892

Really?  No one? Smiley Sad

Product Expert
Posts: 2,945
Registered: ‎10-16-2012

Re: Device not found - connecting Powershot Elph 330HS to Canon MX892

Hello.

 

Unfortunately, the unit is not able to communicate with a digital camera through Wi-Fi. 

 

Please connect the Powershot camera to the Pictbridge port on the front of the printer in order to print from the camera.

 

If immediate assistance is needed, feel free to call us at 1-800-OKCANON.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement