Canon Community Canon Community
 


Reply
Highlighted
Occasional Contributor
Posts: 5
Registered: ‎05-30-2020

Can't update to new firmware on Powershot SX530HS

I am very impressed that Canon chose to update their firmware without warning during a global pandemic with NO customer support.


It is grreat, just GREAT, that I can't connect my Powershot SX530 HS to my iPhone or computer through Wifi anymore.  I now have a very expenisve paperweight.

 

The update will wipe the entire memory card?  Good thing we have a way to get all those pictures saved, right???  Oh, wait a second....

 

So, after borrowing an adapter, and buying and formating a new card, I followed the directions and downloaded the firmward update onto the new card which had been formatted in the camera per instructions.

 

Then putting it back in the camera, it can take pictures.  But when trying to connect to the Canon.Image rather than the old image Gateway, all it does is tell me that I need to update the date and time (which is correct and what it did before)..

 

Not that anyone has major life events happening now while also trying to take care of a job and homeschoolign children, but Canon can't bother answering the #&^*(& phone.  Boy I am so happy I have a Canon camera. 

Highlighted
Product Expert
Posts: 177
Registered: ‎07-03-2019

Re: Can't update to new firmware on Powershot SX530HS

Hi there IHateCanon1,

 

If the date and time are getting lost, that may indicate that the camera's time and date battery is not maintaining a charge. This ususally happens if the camera is not used for a while, the internal battery needs a freshly charged battery in it for about 24 hours to put a substantial charge onto that internal battery so it keeps the time and date. Another potential cause would be if your camera is set to the 24-hour clock and the time is set like a 12-hour clock, for example 4:00 as 4:00 am instead of 4:00 pm which would read as 16:00 on a 24-hour clock. This can cause a problem because if the time and date is not similar to that on the connecting device the software may get confused as to which data it should use.

 

If the time and date are correctly set and the date/time battery maintains its charge, it would be best to follow the instructions on image.canon from the beginning as if you were setting up a new connection to make sure the Wireless connection settings are properly set.

Highlighted
Occasional Contributor
Posts: 5
Registered: ‎05-30-2020

Re: Can't update to new firmware on Powershot SX530HS

Thanks so much for your reply.

The camera had not been used in a few months, but before using it, the battery was charged for at least 24 hours.

Then after the event for which it was used, the pictures were attempted to upload wirelessly to Canon Image Gateway and it said to fix the date and time.
As far as I can tell the time and date are 100% accurate to now. I can’t see any option of military time or not. I can choose to display month or day first but not 12 hour or 24 hour time, that does not appear to be an option.

I have already followed the manual to add a new connection- it finds my old iPhone2 or image Gateway and then tells me to start dedicated app on Target device (I have the new app) and never finds it, or it tells me to fix the time and date (which appears to be correct).

However when I tried factory reset and also to manually do a connection to the updated web service how one would originally connect it just tells me to “set the correct date and time”

Should I randomly start guessing what they think the correct date and time is?
Highlighted
Product Expert
Posts: 177
Registered: ‎07-03-2019

Re: Can't update to new firmware on Powershot SX530HS

Hi IhateCanon1,

 

If you are still seeing the icon for the Canon Image Gateway instead of image.canon, your firmware has not yet been updated. After you put the firmware update on the SD memory card, did you go into the menu and run the firmware update?

Highlighted
Occasional Contributor
Posts: 5
Registered: ‎05-30-2020

Re: Can't update to new firmware on Powershot SX530HS

Hello,

 


Thanks again for your help.

 

I did follow the directions, and it took a few tries.

 

I have updated the firmware.  When I went to Firmware  did not have Firmware update on the menu half the time.  But evenutally I got the camera to admit the firmware is already updated.


The connection to wifi is no longer showing iPhone, iPhone2 or Canon Gateway.

 

Now it just states it cannot connect at all, to any device.  It says to start the dedicated app (and I have my iPhone with image.cannon app open an inch away) then takes 5 minutes and decides it can't find it.

 

It finds my access point Wifi and I entered my Wifi Password.  But can't find image.Canon

 

Any ideas?

 

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement