Canon Community Canon Community
 


Reply
New Contributor
Posts: 3
Registered: ‎01-06-2019

Re: Blank screen on Canon PowerShot SX60 HS

By the way the camera doesn't open, i.e. the lens doesn't advance either.  

New Contributor
Posts: 3
Registered: ‎01-06-2019

Re: Blank screen on Canon PowerShot SX60 HS

Actually, this time the lens did advance, but still no picture on lcd screen.  

Highlighted
New Contributor
Posts: 1
Registered: ‎11-16-2014

Re: Blank screen on Canon PowerShot SX60 HS

I know about hitting the displace button to get the screen back on...but why does it go off ?

Is this something built in ..and if so why??

Respected Contributor
Posts: 1,267
Registered: ‎03-01-2014

Re: Blank screen on Canon PowerShot SX60 HS

In your settings, check your Power Saving settings where you can set the time before the LCD turns off automatically. Yours may be set for a short time. You can also turn off the power saving so it will never turn off too.

New Contributor
Posts: 1
Registered: ‎04-27-2019

Re: Blank screen on Canon PowerShot SX60 HS

New Contributor
Posts: 2
Registered: ‎04-24-2018

Re: Blank screen on Canon PowerShot SX60 HS

Thanks I will try that.

New Contributor
Posts: 1
Registered: ‎07-02-2019

Re: Blank screen on Canon PowerShot SX60 HS

I just tried this and it doesn't work for my camera still not getting both screens to work again. Any other suggestions. i don't know what I hit.

New Contributor
Posts: 1
Registered: ‎08-02-2019

Re: Blank screen on Canon PowerShot SX60 HS

The Display switch that you toggle has done the trick.  The LED screen came on.

JJLaughlin

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement