Showing results for 
Show  only  | Search instead for 
Did you mean: 

shutter release not working S100



I am suddenly having problems with my S100. It will not take the picture when I press the shutter release. In case I had accidentally changed something, I did a Reset to Defaults. Then it worked, briefly, before returning to not working. It also would not let me change My Colors.  Everything else seems to be working fine.  Any ideas?

575 REPLIES 575

Dan, to tell the truth, although I got another S100 to just get the shutter part for transplant for almost two or three months not, I haven't done it because I am totally satisfied with the camera"s" on my Huawei P20 Pro smart phone now! So much so that I have not touched my other cameras for a long time!  But, the S100 is still something to desire of though for a pocket day I shall fire up my soldering iron!!!

@PO You need to melt the solder.
@ Danluckett You are right, it needs to be done with caution. Temperature-controlled soldering iron makes it easier, but the most important is a fine, pointed and clean tip. Temperature of a pointed tip is harder to be controled. Tip tends to be at lower temperature than set, especially for a low-cost soldering iron, therefore, most soldering irons should be set to slightly higher temperature than theoretical one.
Solder used in consumer electronics is lead-free, which requires higher temperatures. 250 degrees should be OK, and that was what I used. From my expirience, the temperature can be higher and nothing bad will happen but the time of soldering should be limited. Soldering for too long makes the flux from the solder evaporate and the solder itself starts to be ... lumpy? (it stops to shine). Then, it is harder to melt it and all the job starts to goes wrong. So my advice is to do the melting fast and you should see that the solder solidifies once more after a fraction of a second.


Thank you, Jakub! That is good tips! I shall try reheating it first and if it does not work I shall do the transplant. I usually blow air into the soldering to cool it faster! Thanks again!

Great post-Jakub this is exactly why I bought a used, working S100 with a waterproof housing for $99 to use at the beach, in pools etc. I was confident, because of all the information found in this very long thread, more like tugboat rope now, that if anything happened I could fix it myself. Switches like this need a stable mount and a flex PCB is not a good idea. You nailed it, great job!

Excellent post Jaykub! Your theory of the flaw is consistent with all earlier reported experiences of temporary fixes. Contact cleaners and temperature changes etc could all temporarily correct a failed or cold solder connection. I think you have nailed it. Very likely the break is in the solder itself rather than in its bond to the copper -- since no flux was needed to make the repair. Congratulations also on reheating the connection without causing heat damage.

If anyone still has the removed defective shutter release assembly, would you please perform a post-mortem to verify Jakub's findings?

A few minutes ago "JAKUB" posted an excellent account of how he discovered and fixed the cause of the shutter problem.  His post was complete with a photo and clear description of what he found and how he fixed it. Soon after I read it, it VANISHED. A bug, or a conspiracy to conceal a design flaw??  JAKUB -- please re-post.

Oh good. Jaykub's post is back

I still have an unworking/unmodified S100 that I will try this on.


I've fix it!

I suffered from the not working release button also. What I've done was soldering the pads of the release button. The button is placed on flex ribbon, which may be a problem because soldered pads may break after many pushes.

I will describe what I've done exactly in case You want to try this fix by yourself.



I've reheated three pads of the release button that are marked as 2. Those are easy to access. I've tried to solder the pads that are marked as 3, but those are hard to reach because the other switch is to close. Nevertheless, the pad most to the right from the group marked as 2 seams to be the problem (pad marked as 4).

My camera is working now 🙂


As a side note: Before I’ve fixed the problem, I've tried to shut a photo with the camera case disassembled. When I pressed the release button, I could not trigger my camera, same way as all S100 owners in this discussion. Nevertheless, when I was pressing the trigger button and I pressed the flex ribbon in a place close to the button and marked as 1, then a picture was captured. I’ve done this few times, and it has always triggered my camera. I assume that pressing the ribbon distorted the broken solder in some way and the proper connection was back. I’ve probed the pads of the release button with camera switched on. When the second stage of the button was pressed and released then the pad marked as 4 was switching between hi and 0V states. Therefore, I assume it is the faulty pad.


Good luck anybody that still uses their S100. I am going on my vacation next week and I hope to capture it with my fixed camera!

click here to view the gallery