cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to Connect to New Wifi - Set the correct date and time

slopatin
Apprentice

I am successfully able to transfer photos from my PowerShot G9X to my Google drive when using my wifi connection at home. However, I am now traveling and unable to connect to another wifi source. 

 

I click on Set and it searches access points and I select the correct wifi connection. It then tries to connect to it but eventually says "Set the correct date and time". The date and time are correct, and even if I change it it still does not work. Any suggestions?

20 REPLIES 20

Hi,

If you solve this problem can you let me know what you did? My son has the same problem with this camera and he's in Brazil so I can't try to help solve the problem from here. Would love to be able to suggest a solution for him to try.

Thanks!

Give me a better understanding if tranfering photo to a cell phone or to a destop computer or to a laptop computer or tablet.

The idea of wifi LAN is that in a certain place the connection between camera and any device is between router and devices are using the same router in any local area network. If you move to another place, you must do wifi LAN of that place. A new connection must be made. I suggested to rename the camera because the default camera is already used, but sometimes it worked. When the camera is moved to a different place, camera gives a different SSID and password ( correct me if i am wrong ) or I have noticed that SSID and key after one month or more  is changed ( pentax camera ) at least one or two character/s  is changed. See at the camera the recent SSID and password to be entered in a new location to your  device.

 

There is also a big change if the device wfi LAN  is in another country. 

Hi,
Thanks for your reply. He doesn't have a phone, so uses the camera in locations with wi-fi to upload images to the canon image gateway. He has succesfully done it from Sao Paulo but now is in Rio Do Sul and isn't able to upload imagies because it says please set correct date and time (although the date and time are actually correct). He has the canon powershot elph 190.I can only talk to him once a week so I don't know more detail than that but can ask him questions on Monday.

At any different place before linking to wireless LAN, reset the camera from its menu to get back to its default setup.

How come it works sometimes with no problems and no changing of any settings and other times it doesn't work at all? You'd think it would at least have the same issue all the time. I took my camera to Canada and Texas and never changed anything. It uploaded the whole time. Yet when I went to Charleston and later to Florida it didn't work when I got there and it also didn't work when I got home again.

... didn't work when I got home again...

 

 

I assumed that there is no wifi LAN connection during the time you activate the devices. Make sure wifi is on first at your device and camera is off. At your device when it says " not connected to camera" then that's the time to power on the camera and  wifi on and get the camera SSID and Password or key.

I tried everything they suggested and nothing worked. I was trying to retrace my steps to remember how I corrected it and I cannot seem to find "exactly" what I did. However, I know for sure I corrected it by reestablishing the wifi link from the Image Gateway. I canceled the links that were there for all services.....such as icloud, Facebook, etc. Then I re-established them and it all worked. However, the frustration is that different things seem to work at different times and I have not found a consistant way to deal with the issues arising from this camera. I have used the camera, including uploading to internet, while traveling with no issues and other times big issues. I have returned home and the camera immediately hooks up to my home Wifi with no problem, and other times it wouldn't hook up again. Now Im having trouble uploading via the USB cable. It's all a nuisance and I think Canon needs to fix what appears to be a software issue. If my cell phone can transition to all locations and take photos and never give me a problem, I am assuming Canon should be able to make a camera function the same way.

Justin1
Apprentice
I have the same problem with my Canon SX620 HS. I DO NOT recommend this camera if you are looking to transfer images on WiFi with ease.

AviRock
Contributor

@slopatin wrote:

I am successfully able to transfer photos from my PowerShot G9X to my Google drive when using my wifi connection at home. However, I am now traveling and unable to connect to another wifi source. 

 

I click on Set and it searches access points and I select the correct wifi connection. It then tries to connect to it but eventually says "Set the correct date and time". The date and time are correct, and even if I change it it still does not work. Any suggestions?



Hello,

i have a Power Shot SX530 HS. I havr done every thing written above. I changed the camera nick name i made the time zone london (since thats were i live) nothing workd.

I was looking forward to using image.canon but saddley i am unable do you have a solution?

Thanks A.R

Please reply as soon as possible.

Hi AviRock,

 

image.Canon is going to use a slightly different process with your camera and with the new service. It is porbably best to contact local Canon support by phone to get yourself setup. They're available Monday through Friday from 8:00-20:00 at +44 (0)207 660 0186.

 

I found the information in the link below.

https://www.canon.co.uk/support/consumer_products/contact_support/

Avatar
click here to view the press release
Announcements