Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to Connect to New Wifi - Set the correct date and time


I am successfully able to transfer photos from my PowerShot G9X to my Google drive when using my wifi connection at home. However, I am now traveling and unable to connect to another wifi source. 


I click on Set and it searches access points and I select the correct wifi connection. It then tries to connect to it but eventually says "Set the correct date and time". The date and time are correct, and even if I change it it still does not work. Any suggestions?


Product Expert
Product Expert

Hi Slopatin,


Thanks for posting.


If you're in a different time zone from your home time zone, when you corrected the time, did you also change the time zone on your camera (recommended)?

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.


I have the same issue.  I can connect to my home wifi with no problem.  But I am unable to connect to a new wifi - and I am in the same time zone.  The time/date has not changed.  

Redo the same wifi connection but you have to give a new name to the camera and not use/same  old name of camera.

I am not sure what you mean. I don’t recall how to give a new name to my camera and if I figure that out do I have to revert to the old name when I return to my home WiFi? I bought this camera specifically to use when traveling so I could upload pictures directly and now I am finding that feature is problematic. So frustrating and time consuming. Exactly what I was trying to avoid.

I figured out how to change the name. I have made sure the date and time etc. are correct, which they are. I am on vacation but the time zone is the same. It has not worked and I am still getting same message. Any advice? This has happened before when I was traveling and when I returned home everything worked fine again. I also have traveled and it has not been an issue. I don’t understand the problem. I have had the camera about 6months and love the photos, but this inability to upload photos is so aggravating.


Doesn’t work.

Everytime you connect camera to a new different router, you must give a new name to your camera and use that new router  SSID to establish a connection. ( sometimes using default camera name works - try it  ).

At your home you can connect because you have already established that connection but if you move to another place a new router is not sensed by the camera that is why you must redo as if a new connection is to be made. During a new connection is to be made,  the default camera appears, you can edit that camera name.

I did rename my camera and it did not work. Unless I am somehow misunderstanding the naming part, but I don’t think so. I never had an option to select a different name when the camera linked to the WiFi here for the first time. Can you possibly send me a link to show me how to do this in case I am simply doing something different than I am supposed to, although having practically read the entire manual again I don’t think so. Why does it happen some of the time when traveling and not others? That doesn’t make sense either. And I’m in the same time zone. Thanks

Hi there!


You'll find a few helpful articles about using WiFi on the G9X on THIS PAGE.


If you've followed the information there, and you still need help, we recommend reaching out to support. Our US-based team is available weekdays from 10am to 10pm (ET) at 1-800-OK-CANON (800-652-2666). 

click here to view the press release