Showing results for 
Show  only  | Search instead for 
Did you mean: 

[PowerShot SX60HS] Cannot transfer photos to iMac - Set thecorrect date and time error


I have a Powershot SX60HS that I connect to my iMac, that is running MacOS 10.14(Mojave), using a USB cable.

I recently took pictures and videos of a family gathering.  I got home and tried to download the pictures to my iMac.

When I connect the SX60HS to the USB cable the iMac recognizes the camera, then the camera immediately disconnects and displays -"Set the correct data and time" on the screen.  I reset the date, time, and time zone on the camera so that is matches the iMac's clock to within one second.  Still receive the set date and time error.


I searched this community forum and found hundreds of posts regarding the "Set the correct date and time" error that pertains to conncting to WIFI and the IMAGE.CANON website.  My camera only has one WIFI connection, a direct WIFI connection to a tablet, so I can use the remote viewing and shooting feature of the Canon Camera Connect app on the tablet.


[Side note:  No I cannot use the camera's WIFI connection at home because the camera is not capable of connecting to a WPA3 wireless network with Radius Authentication which requires a digital certifiacte.  I reside in an area that has an extremely crowded WIFI environment.  WPA2 has failed me twice so I migrated to WPA3 and  RADIUS authentication.]


So if the Set Date/TIme error message is a network related error how and/or why am I receiving this error when connecting via a USB cable?



Odd, is all that I can say.  Make sure the camera is turned off before you connect the USB cable.  Connect and turn on the camera, making sure to avoid accidentally hitting the Wi-Fi button.


How long have you had this issue?  The PowerShot SX60HS is not a current model.  Has the USB connection ever worked?


"The right mouse button is your friend."

The USB connection quit functioning April11th, 2020.  First time I tried to us the USB connection after Canon Image Gateway shut down on March 31st.  I find that is a really peculiar coincidence to say the least considering it worked just fine on March 26th.


I have contacted customer service several times since April 11th, but their only advise is to purchase a new camera even though I still have 3 months of extended warranty remaining.  I bought this camera in late December of 2018 from a retail store.


The USB connection has always worked. It has been the ONLY method I transfered pictures over the 16 months that it worked.  I connect the USB cable to the camera then I only push the power button while facing the front/lens side of the camera.


I have a USB memory card reader that I can use, but that method of transfer is maybe 40% reliable.  There are far too many chances for the SD card to become corrupted during removal or insertion even when devices are powered off.  However the biggest chance of corruption is that Canon devices use a propietary file system that allows the files to be read as FAT32 file system but is not 100% compliant to that standard.  Many operating systems treat the data on the cards as if the file system is corrupt and try to repair it.  This process usually just renders the card unreadable, and requires re-formatting. I learned this the hard way with a Rebel T3i, and a SX10HS, and now I am forced to gamble with this method using the SX60HS.


I am at a complete loss of why this happened.  I think I have an idea of how it happend, but more interested in the why.

Your error message is one that is supposed to only associated with wireless communications.  Check the Canon web site for a firmware update for your camera.  This has been the "fix" for this issue for select cameras.

"The right mouse button is your friend."


Spent an exteded period of time on hold waiting for customer service yesterday 9-4-20.
I got a very definitive answer for this problem.


"Your Powershot SX60 HS was listed as obsolete in 2016, which means it is not eligible for any type of support, nor is it eligible for any kind of repair.  Have a nice day. {click}"


So that means my camera was listed as obsolete two years before I purchased it.


I'm not sure about the rest of you, but it would seem any camera not supported by website the communication capabilities are rendered inoperative the first time it connects to the Canon Image Gateway servers after March 31, 2020.




03/14/2023: New firmware version 1.8.1 is available for EOS R6

03/02/2023: New Firmware Updates Are Available:

EOS R7 - Version 1.3.0EOS R10 - Version 1.3.0
02/24/2023: We've updated Share Your Photos

2/07/2023: New product announcements!

EOS R8 EOS R50RF-S55-210mm F5-7.1 IS STMRF24-50mm F4.5-6.3 IS STMRF15-30mm F4.5-6.3 IS STM
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
11/22/2022: New firmware available for EOS R3, EOS R7 and EOS R10
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version is available for EOS-C500 Mark II
05/26/2022: New firmware version is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
04/26/2022: New firmware version is available for EOS R5 C
03/23/2022: New firmware version is available for EOS-C70
02/09/2022: Share Your Photos is back!
02/07/2022: New firmware version 1.6.1 is available for EOS-1DX Mark III
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.