Canon Community Canon Community

New Contributor
Posts: 2
Registered: ‎09-27-2017

Re: selphy cp910 freeze at home screen

Hi. i'm interested in your help because there's not customer support here in lebanon

New Contributor
Posts: 3
Registered: ‎04-10-2018

Re: selphy cp910 freeze at home screen

This what I was instructed to do to get it back working.
1. remove ink tray
2. remove paper tray
3. unplug power cord
4. press power button 5 times, and then wait 1 full minute before plugging the power cord back in.
5. plug power cord back in and press the power button.
It should boot up properly at this point. Replace ink and paper trays and try to print.
NOTE: The first time I did this after rebooting, I received a "wrong paper size error" when trying to print. I pulled the paper tray back out and then replaced it again and tried printing again and it worked!
I hope this helps, please let me know.
Dan Lyons Kentucky USA
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement