Canon Community Canon Community
 


Reply
New Contributor
Posts: 2
Registered: ‎12-28-2013

"New port could not be created" error on MX 860 Install

Hello everyone,

I'm having trouble installing my Canon MX 860 printer. It's been hooked up to my Dell studio XPS for the past few years but last week I had to reinstall Windows 7 Professional and now I'm trying to reinstall the MX 860, its drivers and scanning software. I inserted the CD and selected network connection (not USB) and then got a message that no drivers needed to be installed as more up-to-date drivers were already installed. When it came time to install the MP navigator software I got an error that it was incompatible with my version of Windows and gave me an option to search the Internet for an alternative or to run anyway. Because I've used the same printer and at the same software in Windows 7 Professional before, I let it run. When prompted, I selected my LAN and entered its password (the LAN was listed twice, one with WPA and one with WPA2, I tried both) and clicked okay, after a few minutes I got an error stating "new port could not be created".

 

I tried running the procedure again but this time let Windows search the Internet for a newer version and was directed to the Canon website where I downloaded more up-to-date drivers. I tried the install procedure using that file but got the same results. I googled the error message and found a possible solution at http://www.techsupportforum.com/forums/f31/new-port-could-not-be-created-118976.html

which recommends running the program cnmnpu.exe from the Canon install disk which apparently "uninstalled the ports and enabled them to be created again properly." However, when I tried this procedure I still got the "new port could not be created" error.

 

I found no other solutions after googling the error message and I'm hoping someone else might know of a solution to this problem. Perhaps there's some registry tweaks that need to be made? I did search the registry and found references to Canon printers but don't feel comfortable making changes to the registry. At one point I tried running the IJ Network Tool found on the Canon website with no luck.

 

Thanks in advance for any info you can provide! 

 

Dan

Product Expert
Posts: 145
Registered: ‎01-09-2014

Re: "New port could not be created" error on MX 860 Install

Hello Quadzilla,

 

Running the CNMNPU.EXE and uninstalling / reinstalling the driver usually resolves this issue. There could be a security or third party software conflict, try disabling your security software and uninstalling / reinstalling the driver. If the issue still persist, try the steps listed HERE to put the computer in selective startup.

 

If the error remains after installing the driver in selective startup, please reach out to our technical support team at the following link:  CONTACT US.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement