Canon Community Canon Community
 


Reply
New Contributor
Posts: 1
Registered: ‎09-05-2013

MX922 Wirelesss connection intermittently drops out

I just purchased the MX922 - using is with OSX 10.7.5. Did the set up, everything worked, printed wirelessly. The next day, the wireless connecticity of the printer went out and wouldnt print. From the menu panel, I renentered the SSID and everything was fine. Next day, same thing. It appears that when the printer goes to sleep it loses its wireless connection and needs to be reset.  Any ideas?

Product Expert
Posts: 215
Registered: ‎08-07-2013

Re: MX922 Wirelesss connection intermittently drops out

Hi aweissman,

 

With some routers, if activity is not detected on a device after a set period of time, the device will be removed from the routing table. When the printer enters standby, it also enables discontinuous reception to save power. This might cause the printer to be disconnected from the router when you attempt to print again.

 

To disable this feature:

  1. Select Setup on your printer's operation panel
  2. Select Device Settings
  3. Select  LAN Settings
  4. Select Other settings
  5. And then Wireless LAN DRX setting
  6. Set this option to Disabled

 

If the device is still disconnected after a long period of inactivity, I recommend contacting your router manufacturer for some additional options or settings you can change within the router itself.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
New Contributor
Posts: 3
Registered: ‎11-01-2013

Re: MX922 Wirelesss connection intermittently drops out

I disabled Wireless Lan Drx, does not help anything. Called already Canon Support, they blame the router manufacturer, what is bull**bleep**. Shut I make a lawsuite against Canon? I just want a printer that works in a Wifi environment, I think thats not to much anno 2013. Please release new Firmware for MX922 to solve this problem.
New Contributor
Posts: 1
Registered: ‎11-09-2013

Re: MX922 Wirelesss connection intermittently drops out

Thank you.  Works for me.  Printer was also failing in wired LAN mode, so also disabled "wired LAN DRX setting".  Printer now works in either mode.

 

Suggestion:  It would be useful to pass this setting change to your Level 1 support group.  When I called them last week to inquire about the problem, the only thing they could offer was to contact the router manufacturer for a possible solution.

Highlighted
New Contributor
Posts: 3
Registered: ‎12-29-2013

Re: MX922 Wirelesss connection intermittently drops out

I've changed the 'DRX setting' as per Mark II above; by tomorrow morning I'll know if this was a Canon false flag. The corporate retards who 'approve' new U.S. auto designs are genetically related to those who find it cheaper to misapply error responsibility versus intelligently owning the error and fixing it.
New Contributor
Posts: 1
Registered: ‎05-20-2014

Re: MX922 Wirelesss connection intermittently drops out

I tried to follow your instructions.  There is no "Setup" on the printer's operation panel.

There's only "WLAN Setup" 

That submenu connects with the wireless access point.  I can get a menu titled "Wireless Lan Settings" by pressing the "Stop" key.  which has 3 items:  "Standard Setup",  "WPS" ,  and "Other Setup".

If i go to "Other Setup" then I see "Advanced Setup" which then scans for a wifi connection.  I then select my router, and about all it lets me do from that point is to enter the WPA2-PSK(AES) password.

 

I don't see anything in the menu items on my panel that in any way let me get to a Wireless LAN DRX setting.

 

Please clarify what buttons to press to get there.

 

New Contributor
Posts: 1
Registered: ‎05-21-2014

Re: MX922 Wirelesss connection intermittently drops out

Push the Menu button, then go to the "Setup" icon, select it, then go to the left to "Device Settings", select it, go to "Lan settings", go to "Other settings", then down to "Wireless LAN DRX setting" (or Wired LAN DRX setting" if you are wired to your router), then select "Disable".    It has worked for me.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement