Canon Community Canon Community
 


Reply
Highlighted
New Contributor
Posts: 1
Registered: ‎08-07-2013

How do I get my new MG5420 to print duplex?

Have new Mac and new MG5420 that is supposed to print duplex but wont.....or cant.  The print boxes from the applications do NOT have any place to choose duplex........

Highlighted
Product Expert
Posts: 257
Registered: ‎12-07-2012

Re: How do I get my new MG5420 to print duplex?

Hello Retiredguy,

 

Please try clicking on File > Print within the menu of the application you are printing from.  Look for a drop-down menu with the heading of either "Layout," "Copies and Pages," or the name of the application you are printing from.  Change this to "Duplex Printing & Margin" to see the various duplex options.

 

Hope this helps!

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.
Highlighted
New Contributor
Posts: 1
Registered: ‎08-24-2013

Re: How do I get my new MG5420 to print duplex?

I got to this thread because I had the exact same problem.  I set up my printer wirelessly to connect with an Imac and a Macbook Air, both with Mac OS Mountain Lion.  When I asked it to print, there were only a few options.  There was no duplex available, nor were there color options.  After trying a number of options like reinstalling printer drivers, I finally hit upon a solution.

I connected my printer to my Imac with a usb cable, and it showed up in my system preferences as "Canon MG5400 series -2" I enabled "share this printer on a network."  Immediately on my Imac, when I went to print, all the print options were available including duplex and color options.

I then went back to my laptop, and found the options were still NOT available.  However, I clicked on the "Printer" line at the top of the Print dialogue box, and it let me choose "Canon MG5400 series -2." As soon as I did that, all the advanced print options appeared on the Laptop Print dialogue box as well.

I don't know if this is the only way to fix the problem, but it certainly worked for me.  I know the option that I have repeatedly seen of "Look for a drop-down menu with the heading of either "Layout," "Copies and Pages," or the name of the application you are printing from.  Change this to 'Duplex Printing & Margin'" simply does not work, as the "Duplex Printing & Margin, just did not appear.

I hope this works for you as well.

Highlighted
New Contributor
Posts: 1
Registered: ‎12-23-2014

Re: How do I get my new MG5420 to print duplex?

[ Edited ]

The following should work:

 

  • File-Print
  • Print using dialog
  • Just below the Orientation pictures, choose Duplex Printing & Margin from the pull-down (usually Layout shown)
  • Enable duplex printing
  • Under Preset, save this setting as a new preset, e.g. DUPLEX

The next time you print, you can just select the preset you saved above.

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement