cancel
Showing results for 
Search instead for 
Did you mean: 

"Could not install the scanner driver" MF227dw

phazex3375
New Contributor

MF227dw has been great for windows 7 as a network printer and scanner. After moving to windows 10 all printer functions work fine but I cannot figure out a way to get my scanner driver installed. Windows won't even recognize a scanner is available for use. Have tried a few things including disabling windows ability to choose a default printer as well as installing and uninstalling the toolbox software several times. Any help would be appreciated

 

scanner error.png

46 REPLIES 46

tehal
New Contributor

Hi James,

Thank you very much for your help. But I have already found solution.

I tried many times what you suggested but in vain. I appreciate the Cannon Technical team who did their best to fix my problem online. The specialist from cannon uninstalled the scanner driver and reinstalled repeatedly.But the specialist couldn’t install scanner driver on my computer. Finally, the specialist gave up saying that scanner can’t work on my computer. He suggested to contact Microsoft to solve this issue. But I never give up.

I got  windows 10 repaired using back up in my computer, uninstalled the scanner driver and reinstalled it from Canon website. It did work. I appreciate everybody for their suggestions offered.

Sonya1
Product Expert
Product Expert

Hello phazex3375,

There must be a program interfering with installation of the scanner drivers on your Windows 10 computer.  If you have not already done so, I suggest you place your Windows 10 computer in a Selective Start Up, then uninstall and re-install the drivers from our web site using the steps at this LINK while you are in Selective Start Up.

To place you computer in a Selective Start Up, please follow these steps:

 1.  Right-click the Start button.

 2.  Select 'Run'.

 3.  In the Run window type: Msconfig

 4.  Select OK.  If the UAC window opens, type in your password and select OK.

 5.  In the System Properties screen, choose 'Selective Start Up'.

 6.  Uncheck the box labeled 'Load Start Up Items'.

 7.  Click Apply.

 8.  Under the Services Tab, click on 'Hide all Microsoft Services' at the bottom of the window just above the OK button.

 9.  Click 'Disable All'.

10.  Click Apply.

11.  Click Close.

12.  Restart the computer.

After you successfully scan a document, please follow these steps to return your computer to Normal Start Up:

 1.  Right-click the Start button.

 2.  Select 'Run'.

 3.  In the Run window type: Msconfig

 4.  Select OK.  If the UAC window opens, type in your password and select OK.

 5.  In the System Properties screen, choose 'Normal Start Up'.  The Services tab automatically returns to the previous settings.

 6.  Click Apply.

 7.  Click Close.

 8.  Restart the computer.

 

If you need more assistance and you're in the USA, please click http://Canon.us/ContactCF for our US-based support. If you're outside of the US, please click http://Canon.us/4xf7 for support options.

 

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

oleksa
New Contributor

Dears

 

I have the same problem as it is described here

 

setup files were copied to c:\drivers folder (it is short and has no spaces)

 

I've tried Limited startup, uninstalled Canon MF5800 drivers and tried to install it again - error is the same

I've removed programFiles\Canon\**\*.dll files (one of them was locked by windows image acquire service but this did not help.

Then I returned PC to the Normal startup mode and tried one more time but no luck again

 

Seem that only one option left is to reinstall Windows 10 x64

 

But is it possible to generate some log file by Setup.exe ? 

 

I'd like to check what step (or file) causes this error to be generated before reinstalling Windows. I suppose that if there is such possibility to generate log file it will show what causes setup to fail. I've checked Event viewer but there is no error about setup failure.

 

Regards

Tom279
New Contributor

I am having exactly the same problem with MF244dw. This seems to be common issue of this kind of product. Hey canon please give us the solution. Thanks

aharabedian
New Contributor

Hello,

 

I had this same issue and have found a fix that worked for my user.

 

I logged in via the windows 10 built in admin account. After I was logged in, I fully disabled windows firewall. Once windows firewall was disabled I was able to install the full driver package as well as the scanning toolbox. The scanning utility worked on the built in admin account. When I changed users to the standard account, I had to reinstall the scanning toolbox, but it also worked. I then reactivated windows firewall and scanning worked on the standard user account.

dozel
New Contributor

Hi....

I'm also experincing this problem as of July 17, 2019!!! 

I bought a new 632CDW. who would thought that the installation of a driver could be this difficult. 

 

I did the following as some of you suggested:

Moved the up-zipped folder C drive

shorten the folder name to 3 letters long

Removed all other Canon devices/drivers (I have no Canon product ever installed on my laptop)

 

I'm running windows10 64bit. Disabled Windows Firewall, Disabled McAfee firewall.

I was able to install the scanner driver and the toner status, but failed the printer's driver.

I chose the via internet way since I don't have a USB cable....

 

I'll try another day or two, if still can not be solved, I will return this product for full refund....This is just rediculous. 

 

Patrice
Reputable Contributor

Hi Dozel.

 

Based on the steps that you have already taken, we will have to recommend that you call our telephone support group at 1-800-OK-CANON (652-2666), Monday - Friday 10:00 a.m. to 6:30 p.m. ET (excluding holidays). The representative can perform additional troubleshooting steps to resolve the issue.

Did this answer your question? Please click the Accept as Solution button so that others may find the answer as well.

dozel
New Contributor

Problem solved.

 

By re-install windows10 (clean re-installation)

dozel
New Contributor
Your support group working time overlaps with my working time. But thank you Patrice for your quick response.

sasser
New Contributor

Hello there;
You can solve your problem by performing the following steps in order.

1- Remove canon printers from devices printers section.
2- Add the program, uninstall the printer driver and delete the Canon Toolbox program, if any.
3. Delete the C: \ program files \ canon folder.
4- Delete the folder c: \ windows \ system32 \ spool \ driver
5- Extract the updated driver zip file you downloaded to the c: \ drivers \ canon directory.
6- Install from this directory. select the pcl6 driver and scan driver when installing.

Good luck with.