Showing results for 
Show  only  | Search instead for 
Did you mean: 

new MF753Cdw, computers won't connect, Mac OS x Sonoma 14.1.2


Trying to set up 753cdw first printer in 1.5 decades.

Followed instructions to the letter. Printer won't configure, won't print.

Mac reports connection failure. 753cdw reports "Wireless LAN Status: Bad". Internet is fine, router sees the printer has connected.

I've shut off all wireless security, still doesn't connect.

Can we get some idea what's missing in this picture? I've done the setup, have 2 people scouring the manuals and nothing.



Thanks for joining the conversation, heymikey80!

So that the Community can help you better, we need to know exactly which version of macOS is running on your Mac. That, and any other details you'd like to give will help the Community better understand your issue!

If this is a time-sensitive matter, click HERE search our knowledge base or find additional support options HERE.

Thanks and have a great day!

Hi Danny,

We are running MacOS Sonoma 14.1.2.  The printer driver we downloaded was supposed to work with Sonoma 14.1.2.

Thank you!


Update: FWIW, both the Win10 machine and the Mac Sonoma machine, *both recognized the printer as it came up*. MacOS appears to have had it installed and installed properly. Win10 never managed to get through the install but I had the "Install Printer" dialog onscreen when the printer came up, and when it came up, it appeared in the dialog.

So the printer *driver* software appeared to be ready for the printer -- it's just that the printer had not connected to the network that was specified. (Even though I had to click on it numerous times while going through the setup steps and changing the network settings.)

OK, after searching far & wide for users of the printer on Twitter, someone got into a discussion with me about the different things I tried.

While it's possible I may've fat fingered onto one of the other six networks broadcasting here, I was mystified early on. I had specified my network as requested by the setup software prior to everything, but I found I was constantly pushed to a page to respecify it after it failed the first time.

The oddity: long after I'd specified it, the printer popped up windows saying it had changed (from a 192.#.#.# to a 209.#.#.#).

I had tried a static IP. That never worked.

So I buried the printer. It's literally in a broadcast hole in my basement. Now it doesn't jump networks, either.

I reconfigured it. Shut down the printer. For a long time (5 min). Restarted the printer.

It appeared just fine on my Win10 and Mac machines.

It doesn't show under Android's "Canon PRINT Business". Obviously I can't hand the app an IP address, it's not static.