Showing results for 
Show  only  | Search instead for 
Did you mean: 

MF4150 scanner not work on windows 10

Hello everybody, after fill this long procedure: and install all the newest driver / Toolbox, I still not able to scan from my device. Inside the device manager I can see under scanning devices an item called Canon MF4100 series and the so tell me that the device is working ok. Therefore, with Toolbox, when I press any scan button, no windows appeare. I have try also with the Microsoft Scanner application from the store but the application stay on wait... status for ever. Also in Toolbox settings there is the Canon MF4100 series as device to use but nothing is possible. Thanks for the attention. Marco


I had a similar issue after upgrading to Windows 10, and through trial and error, I fixed it through permissions. Installing Windows 10 had changed permissions on my computer for some reason.

Try this:


Find the folder where the photos/documents are normally saved.
Right click and select Properties
On the Security tab, select your username, or the home group, in the list of user names
Click 'Edit'
Click on 'Allow' for all permissions.
Click 'Apply'


Hope this helps you too

Thanks for the suggestion, I think the folder is the Picture folder of the current user (there are no settings for select any folder in Toolbox). The permissions are already all set....anyway thanks!

1. I have tried several methods but none of them worked.
2. I turned off the power of MF4150, tried these steps in the folder named "PICTURES" (for every GROUP or USER NAMES), then turned on the MF4150, now it works. [except the auto-feeder feature doesn't work all the time]


Go to  "Programs and Features" and uninstall the Canon drivers and restart the computer. Go back to programs and features and uninstall the the Canon tool box. 

Turn off your MF4150 printer and disconnect the USB cable from your computer.


Download and install the Mf4150 drivers and the  Canon Tool Box.


Then turn your Mf4150 back on and reconnect the USB cable.

The scanner should now function properly.

My scanner worked fine after I reinstalled the drivers.

But, after the latest windows 10 update my scanner stopped functioning again.

I tried reinstalling the drivers and toolbox with no success.

Prints and copies with no problem but if I try and use the toolbox I get the message that the computer cannot communicate with the scanner.


Do the drivers need to be updated for the latest version of Windows 10?

Mine did the same thing with the latest Windows 10 update to 1511 (a.k.a. Threshold 2, build 10586.0, Fall Update).


To see what version you have, type this into a Run box or cortana:



I have 10586.14


See my reply to the other thread about Windows 10 scanning:


On a related note, I am networked to a Canon MP640 color inkjet. After the last Windows update this printer showed as "offline" both on the network and on the computer it was connected to. I tried to go to Canon software on the computer and found that it was gone.


When I went to settings, it showed that the printer existed but I could not access it's functions.

 It said that an app was available for this printer.

I downloaded the app from the Microsoft Store and the printer again functioned normally.


Perhaps an app for the Canon MF 4150 may show up in the future?


Here is what I found which solved the problem with scanning.


1. Open the Windows desktop.
2. Right click on the MF Toolbox icon and click properties.
3. Click the Compatibility tab, then click "Change settings for all users".
4. Put a check next to "Run this program as an administrator", then click Apply and OK.
5. Click OK again on the properties screen.

for everyone who is still struggling to scan with their mf4150 on window 10 - canon has just released a patch which fixed my scanning issues - go to canon downloads and follow the simple instructions.