Canon Community Canon Community

New Contributor
Posts: 1
Registered: ‎09-24-2018

Re: MF Toolbox doesn't work on Windows 10


I couldn't manage to fix the ToolBox problem, but i could manage to reach my imagerunner through the network as a scanner. I just had to make a firewall rule and use WSD protocol (check whether that is supported, my imagerunner got this feature).



Source IP: your network printer/scanner IP.

Source port: any.

Target IP: your PC's IP.

Target port: 5357 (TCP).


This way i could manage to reach it with the basic Windows 10 Fax&Scan feature. Steps (for imagerunner):

1. Select Scanning on your printer.

2. Select Remote scanner on your printer (yes, on your printer).

3. Just press Win(dows) button on your PC, type in "Fax" (without quotes) to launch the basic Windows 10 utility and you shall see your scanner (remember, this is a WSD solution).


I hope this helps and i hope they'll release a Windows 10 (Windows 7 is fine still) compatible ToolBox.....





New Contributor
Posts: 1
Registered: ‎10-10-2018

Re: MF Toolbox doesn't work on Windows 10

I just had to rebuild the operating system on one of the computers on my 4 computer network 2 days ago and wasn't even able to get the Canon Toolbox to Operate - The same thing everyone else is talking about.  "A Supported Scanner is not installed etc....".  With that I did a complete removal and reinstall of the drivers along with the patch that on the Canon website.  <The mark of insanity is when you continue doing the sam thing expecting to get different results.>  I reinstalled it twice and now not even the Canon Toolbox Icon shows in the Apps on my desktop.


There is a "Canon Office Printer Utility"icon that shows up in my apps (I believe that it was something that Canon's Web Site told me to download.  When I go to that app it responds but nothing happens.


So now yesterday morning I scanned several items from my other compluter and then in the afternoon it started giving me the same message.  It was then, after reading all of this business that I put it together that Yes-I like any good microsoft owner had performed an update midday yesterday.  So now I understand why Microsoft is in such low regard by so many people.


At this point at  I have a worthless Icon on the one computer and none on the other so I guess I won't be doing any scanning until someone develops a fix for this!  I'm not dumb, but I'm not extremely fluent the in's and out of all this IT jargen and need these Guru software people to give me a fix that can be easoly explained in a few steps!


Pleeeeeeeeeease Canon and Microsoft gets your ducts together and stop wasting our time and Money!!!!!!!!!!

New Contributor
Posts: 1
Registered: ‎09-30-2018

Re: MF Toolbox doesn't work on Windows 10

Canon takes a netoriously long time to resolve these kinds of issues. It took a long time for the last scanner patch. The Windows Fax and Scan app seems to work in the mean time. 

New Contributor
Posts: 1
Registered: ‎12-05-2018

Re: MF Toolbox doesn't work on Windows 10

I will describe the solution to the problem related to MF Toolbox.
Namely-hang installer Canon MF Toolbox 4.9.


Installed Windows 10, licensed, updated.
One fine time, Toolbox stopped scanning.
Decided to uninstall and clean everything, install again.


But after uninstalling I can't install Toolbox.

The installation process stops at the stage of the installation process.


The problem is solved as follows. Start Task manager. The process of Tollbox installer (setup.exe) search in the Details tab. Right click on process of Toolbox installer. Then Analyze wait chain. Then kick the process in the chain that stops the installation.


I had this app from Logitech...

After that Toolbox installation was succesfuly. Scaner worked as usual.


o7 Cmdrs!)

New Contributor
Posts: 2
Registered: ‎01-11-2019

Re: MF Toolbox doesn't work on Windows 10

Regarding "A Supported Scanner is not installed etc...." when not running as an administrator...


I just installed a great open source alternative to the chronically broken Canon toolbox: NAPS2 ("Not Another PDF Scanner 2"). The only downside for use is that you can't start the scan software from the printer/scanner itself - you have to put the printer/scanner in "remote control" mode by pressing its scan button and selecting "remote.". Then you run the NAPS2 application and click its scan button. For my use case, that's fine.


I configured it to use the TWAIN driver (that's the only choice that worked for me). To make it as simple as possible for the user (who simply wants to scan business documents to PDFs), I created two "profiles:" one that scans from the document feeder and one that scans from the glass. Both have "multiple pages in one file" and "auto save" set so a "Save As" dialog box appears when the scan is done. I also have it set to clear its cache of scanned pages after it saves the PDF.


I was going to use VueScan as recommended in a reply on this thread years ago, but decided to try an open source alternative first if I could find a good one. NAPS2 worked just fine; the user is happy; we don't have to discard and replace an otherwise functional multifunction printer that was obsoleted by Microsoft and Canon.


When I searched for this problem on Google, I should have immediately realized that there would never be a lasting fix from either Microsoft or Canon. My search result appeared on page 36 of this 3+ years long thread, and it is not resolved to this day. I first tried to diagnose the toolbox myself, running system call traces with Microsoft/SysInternals ProcessMonitor, comparing working and non-working traces (from administrator and non-administrator accounts). I hoped to find some registry entry or file that needed an access rights change, but could not find it. Even if I had found it, I realize that my victory could be short-lived. Many posts on this thread talk about the problem resolving and reappearing as Microsoft releases updates.


My advice to subscribers to this thread: try a third party scanning app like the open source NAPS2. If that doesn't work, donate your machine to someone who can use it for what it is, and buy a new machine. Make sure it is a completely stand-alone, self-contained, self-sufficient appliance that does not rely on soon-to-be obsolete software running on a soon-to-be obsolete computer to do the functions you care about. If you want it to generate PDFs, it must do it itself. If you want it to email them, it must contain an SMTP client itself. If you want it to deposit files on a file share, it must connect to the network file share and save the files there itself. The multifunction scanner that I use in my office is built that way, and though at least 15+ years, old it scans PDFs to email and JPEGs to a file share as well as ever.


My ad vice to Canon, if anyone is listening, is to contact Chris Jackson at Microsoft about his "Desktop App Assure" program, where he offers Microsoft engineering assistance to both large enterprise users and application vendors to improve Windows' application compatibility, either by getting Windows not to break things or helping the vendors of broken things fix them.

New Contributor
Posts: 3
Registered: ‎02-13-2019

Re: MF Toolbox doesn't work on Windows 10

[ Edited ]

Is no REAL SOLUTION to this issue...

I have it this year (2019) few times...

Some time has solved just restarting the PC and the printer...some time I reinstalled de software/drivers... 

But I found the MAGIC solution... Smiley Very Happy

Trust me...I'm not  use every day, but when I use I m ake from 50 up to 200 scans. (at 100 need to restart the process...). And I buy this model because I can scan from printer directly to my solution...100% working


0. I have Windows 10 (OS) and i7 and more at need a server (or a 24h PC) if you are in a company network

1. Install a virtual machine solution - I installed Oracle VM Virtual Box (free version)

2. Make a virtulal machine with Windows 7

3. Configure a shared folder on your PC (server) and mount in the Win 7 machine (on a network, mount on every machine)

4. Install the printer on Win 7 virtual machine

5. Done. Scan from your printer to Win 7 VM (to shared folder) and all images will be visible over the network, to all stations.


P.S. Let's presume you will make a folder named "shared" on D: partion from your server/PC. Then, after you give all permissions, you need to create a subfolder in "shared", let's name "printer". On Win 7 VM you will set this path for your scans (you cannot set the root "D:\shared". Then on every station (or your Win10 PC) on desktop you can put a shortcut to "D:\shared\printer" folder. And you can change the icon of this shortcut...if you want... Smiley Very Happy Now when you double-click on the new shortcut you will get instant access to all scans (in a company will be required a management between users scans...)

New Contributor
Posts: 2
Registered: ‎01-11-2019

Re: MF Toolbox doesn't work on Windows 10

Capturing a snapshot of a working configuration in a VM where Microsoft can't mess it up is a brilliant solution! (if getting MF Toolbox to work is your goal).


For our company, I chose to redefine success as being able to scan to the PC without the requirement that the scan button launch an app on the PC. We uninstalled MF Toolbox and installed NAPS2 instead. This was an acceptable solution to the user.(Users who have been unable to scan for some time are quite willing to accept an alternative, even if it doesn't match feature for feature to what they had before.)


I now care about MF Toolbox even less than Canon does (if that is even possible - Canon clearly has almost no interest in it at all to let this issue drag on so long).


Canon would do well to endorse NAPS2 and link to it from their own web site.

New Contributor
Posts: 3
Registered: ‎02-13-2019

Re: MF Toolbox doesn't work on Windows 10

[ Edited ]

Sure, NAPS2 can be a good solution too. I don't know if you can batch scan with NAPS2...I will presume yes.

But is other COOL feature in MF Toolbox...external application... It's very useful for batch processing.

I will give you an example: I have a online shop and I sell collectibles.

When I scan, I have many items on the same sheet. Because of white background, all the images can be easily detected and extracted.

I made my application (I'm IT engineer and also programmer, but I can bet are many such application on the market).

Now, every scan will be processed and images no extra work on cuting/manual editing after scan.

80% of my acquiring work is automatically done !

I need MF Toolbox !


P.S. Other solution for such job is to use Photoshop and use scripts, but then you are stuck on patern (all your items need to be in a fixed position)


PSS (edit): post-processing can be useful if the company want to put a watermark on every scan...

or want to monitor all scanings so will need an application that will do an extra copy of every scan and save it in a secure location...and so on...


and thank you for "brilliant" Smiley Very Happy

New Contributor
Posts: 1
Registered: ‎03-14-2019

Re: MF Toolbox doesn't work on Windows 10

The first time I installed the scanner and printer drivers I had no problem. Reinstalling a year later would not allow NETWORK Scanning. The Canon Scan tools would not load, but the printer worked wirelessly


I found this Scanner-only version at Canon Malaysia that installed (not available on Canon USA). So now I can use my network scanner again

powered by Lithium

LIKE US on Facebook FOLLOW US on Twitter WATCH US on YouTube CONNECT WITH US on Linkedin WATCH US on Vimeo FOLLOW US on Instagram SHOP CANON at the Canon Online Store
© Canon U.S.A., Inc.   |    Terms of Use   |    Privacy Statement