Showing results for 
Show  only  | Search instead for 
Did you mean: 

MF Toolbox doesn't work on Windows 10


I have a MF4570dn, and recently upgraded from Windows 8.1 to Windows 10.


I can no longer scan using the MF Toolbox utility.   I had MF Toolbox 4.9 installed before the upgrade, and it worked just fine.  After the upgrade, I get "Cannot communicate with the scanner" error dialog:






I thought I would try to reinstall the MF Toolbox utility, but there are two problems.


1) The downloads page shows no downloads for Windows 10 for this printer. This should be updated.


2) I downloaded the one for Windows 8.1, and tried to reinstall, but it just hangs at the "Processing Installation" screen:




I've also tried to uninstall the existing MF Toolbox first, and it also hangs at this same dialog.


I've also tried various other things without success:

- Connecting via USB instead of Network.  It detects the scanner, and MF Toolbox can switch to that device, but it still gives a communications error.

- Trying the built-in Windows Scan app instead of MF Toolbox.  It uses the WIA driver.  It barely starts to scan, then immediately cancels.


Please Canon - forward this to your engineers and provide a fix asap.  I cannot use my scanner on Windows 10.


(I can use the printer functionality just fine.)


Thanks.  My model's links are different, but the new software appears to work.


Also, to get the old toolbox uninstalled, I had to reboot into safe mode.  Otherwise the uninstaller just hung.  Then booted back into regular mode, removed all traces of the existing printer, then reinstalled the new software and it works great.

View solution in original post

434 REPLIES 434

I had the same error with my MF631Cn under Windows 11 for months: "Cannot communicate with the scanner".

The WIA service solution by Piers_A worked (permalink #M2130).

Thank you very much

EDIT: wrong; my issue was in fact fixed by simply pluging the usb plug in the "right" usb port on the computer. I was expecting the scanner to work on any usb port; for some reason, it isn't. So nothing to do with the WIA Service account. Thanks anyway.


I have the same problem. I can print, but cannot scan now that I have Windows 10. Please do something.

Mine does not either.  I spent an hour with canon on the phone yesterday, deleting this and that and round and round and restart and he finally told me Canon does not have an answer or a solution.  He said brand new Canon's will not install the toolbox either.  Without the tool box, the scanner will not scan to PDF files, so it is basically worthless.  So I am at a loss. You would think that with their staff and resources they could come up with a fix.


Since installing Windows 10, MF Toolbox for my Imageclass4570dw doesn't work. I'm able to print, but scanner doesn't work. Driverdetective wasn't able to help. My computer savy son-in-law was able to scan a document in .jpg after spending about an hour trying different approaches (but PDF scan option didn't exist). Now, I can't scan anything (again).


Canon, please get this fixed.


I have the same very frustrating problem!  Pleae fix this problem!




I am French. I have a MF8580cdw, and in august I upgrade my computer from Windows 7 to Windows 10. Since August, I don't scan with my MF TOOLBOX utility I just can print.


Before, I bought my MF 8580, I had SAMSUNG CLX 3175 FW and I scanned with SmarThru 4 Utility. Now, I use Smarthru 4 Utility for my MF 8580 SCANNER. I just change the SCANNER adress.


The interface of the Smartru 4 is more friendly than MF Toolbox and it's a freeware


Best regards




Windows 10 was release in July! We're in October and still no fix from Canon.

Come on Canon!!


See the solution by Piers_A - it worked for me.


I had Windows 10 installed and everything was working properly until Windows 10 update 1511 took place couple days ago.  The scanning function did not work anymore after MF Toolbox was update to

I uninstaledl both Canon driviers and MF Toolbox and re-installed both from the original cd and everything is now working fine!


Can print or fax. Can also use Windows fax and scan. MF tool box dialog box not accessible. Cannot install or uninstall MF toolbox 4.9. Installation/Unintallation cmd not responding. Can do it in safe mode but still has no dialog box access.

08/18/2023: Canon EOS R5 C training series is released.

07/31/2023: New firmware updates are available.

CR-N700 - Version 1.2.0

CR-N500 - Version 1.3.0

CR-N300 - Version 1.3.0

CR-X300 - Version 1.1.0

06/30/2023: New firmware version is available for EOS-R5 C

05/31/2023: New firmware updates are available.

EOS R6 Mark II - Version 1.1.2

EOS R6 - Version 1.8.2

EOS R7 - Version 1.3.1

05/18/2023: New firmware updates are available.

EOS Rebel T100 - Version 1.1.0

EOS Rebel T7 - Version 1.2.0

EOS 5D Mark IV - Version 1.4.0

EOS 6D Mark II - Version 1.2.0

PowerShot Elph 360HS - Version

PowerShot SX420 IS - Version

PowerShot 620 HS - Version

PowerShot SX720 HS - Version

PowerShot G1X Mark III - Version

PowerShot G7X Mark II - Version

PowerShot G9X Mark II - Version


04/20/2023: New firmware version 1.4.1 is available for EOS R3

03/30/2023: New firmware updates are available.

EOS R5 - Version 1.8.1

EOS 1DX Mark III- Version 1.7.1

Speedlite EL-1 - Version 1.0.2

03/30/2023: Product Advisory for EF50 F1.2 L USM

03/30/2023: Product Advisory for EOS R10

02/24/2023: We've updated Share Your Photos

2/07/2023: New product announcements!

EOS R8 EOS R50RF-S55-210mm F5-7.1 IS STMRF24-50mm F4.5-6.3 IS STMRF15-30mm F4.5-6.3 IS STM
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5