Showing results for 
Show  only  | Search instead for 
Did you mean: 

MF Toolbox doesn't work on Windows 10


I have a MF4570dn, and recently upgraded from Windows 8.1 to Windows 10.


I can no longer scan using the MF Toolbox utility.   I had MF Toolbox 4.9 installed before the upgrade, and it worked just fine.  After the upgrade, I get "Cannot communicate with the scanner" error dialog:






I thought I would try to reinstall the MF Toolbox utility, but there are two problems.


1) The downloads page shows no downloads for Windows 10 for this printer. This should be updated.


2) I downloaded the one for Windows 8.1, and tried to reinstall, but it just hangs at the "Processing Installation" screen:




I've also tried to uninstall the existing MF Toolbox first, and it also hangs at this same dialog.


I've also tried various other things without success:

- Connecting via USB instead of Network.  It detects the scanner, and MF Toolbox can switch to that device, but it still gives a communications error.

- Trying the built-in Windows Scan app instead of MF Toolbox.  It uses the WIA driver.  It barely starts to scan, then immediately cancels.


Please Canon - forward this to your engineers and provide a fix asap.  I cannot use my scanner on Windows 10.


(I can use the printer functionality just fine.)


Thanks.  My model's links are different, but the new software appears to work.


Also, to get the old toolbox uninstalled, I had to reboot into safe mode.  Otherwise the uninstaller just hung.  Then booted back into regular mode, removed all traces of the existing printer, then reinstalled the new software and it works great.

View solution in original post

434 REPLIES 434

What is 'preview scan?'

I think it just lets you see what the image looks like before you save it.

Thanks for this, it worked for me too. I have an mf4370dn

I have the latest version of Windows 10 that came out in fall 2015. I used to be able to scan, but after the update, it didn't work. Here is my list of things to get the scan function working...


  1. I already had the printer driver installed. I think mine was a 64-bit driver for Windows Vista/7/8/8.1. The scanner driver seems to be included in this.
  2. Installed the old MFC scanner driver. Actually, it's a program not driver. It is called Canon Toolbox. Mine is an ImageClass MFC5770 with USB and Network connection. As always, I the scanning function will only work with the USB connection on this type of old multifunction.
  3. At this point I found out that Canon Toolbox will not run, even with compatibility settings. I think it used to run on Windows 10, but no more worky for me.
  4. Per another person's tip, I installed and ran the Microsoft Scan app from the Windows 10 Store. It did not work. I could do a Preview scan and see a portion of a page. But the scan function had an error "something went wrong."
  5. I tried a regular scan from a standard program rather than an app. In my case, I have already installed Foxit Reader PDF software. Other PDF and photo editing software likely has this ... Adobe Acrobat does. Hamrick software has a lot of scanner software, like Vueprint and others.
  6. From the program's menu, I selected "From Scanner" to begin a scan. It has a simple menu, it detected my WIA scanner driver (very important) and was able to scan like the olden days with Canon's scanner driver interface.
  7. I was able to save a PDF, and it gives options to scan multiple pages to PDF.
  8. Did I mention that Foxit Reader is free?!
  9. Note: Changing the startup options for the WIA service did not work for me. To try that, see and scroll to Piers_A's solution.

This means to me that Microsoft has hidden or obfuscated the old, tried-and-true WIA scanning interface. It is apparently still available somehow to the older programs that use this. I think WIA is actually newer than the older TWAIN driver, but I am not sure. Anyway, try the programs I mentioned and see if they can work for you.


One more thing: I have my Canon printer on the network and connected to USB. I am assuming the scanning happens over USB, but I have heard WIA works over a network.

The more things change the more they stay the same.  For a brief shining moment my D530 scanner was recognized by MFT.  I had followed the advice of another contributor here.  Canon, after all, thinks this forum is simply for venting, not providing any usable help. 


That community member advice, adding my twain-32 path to the PATH environmental variable worked for a while.  Now, suddenly, that addition is gone and adding it back provides no help.  This is a severe case of Canon not working with MS to ensure compatibility.  I have no scanning capability almost ten months out from upgrading to Windows 10.  Thank you, Canon, once again, for stellar service and concern for your customer.



I think I may found a solution to MF Toolbox Problem. I realized that problem starts after Windows update.


System and device:

Windows 10 Pro 64 bit

Canon i-SENSYS MF4890dw (I think it's a European version imageCLASS)


Solutions I tried:

1. Reinstalling drivers (I downloaded newest from Canon website).

2. Reinstalling MF Toolbox (I downloaded newest from Canon website).

3. Installing Patch from european Canon site (it was proper for my device).

4. Added a path in system enviroment variable (found it on this forum).

5. Changed properties in WIA in Windows services (found it on this forum).


Nothing worked and I wanted to give up and start using Windows Scan App...


The solution that worked for me:

1. Press Windows button an type "update"

2. Go to Check for updates (Windows)

3. Go to "Update history" (just under the "Check for updates" button). Find the latest one that is not for Adobe player or other software - just something like "General update for Windows 10 systems Version 1607 based on CPU x64 (KB3200970)" - sorry for translation, I don't know how it is in english.

4. Go to "Uninstall updates" (at the top) - new window will pop up.

5. See updates group "Microsoft Windows" (in my case it was the lat one) and find the latest update (dates are at the right of the window).

6. The latest one that stands for "Security update for Windows" or "Update for Microsoft Windows" and has the same symbol e.g. "KB3200970" as you found in step 3 should be uninstaled. Just right clik and uninstal.

7. It will take a while, so be patient. After uninstaling, click yes to restart your computer.

8. After rebooting, probably the problem will persist. My computer downloaded the same update I just uninstalled and prompted me to reboot to install it again. After the update was installed again (during rebooting), my Toolbox started working! And I'm also able to use my device to scan directly to my computer.


I think it's the proper solution, because it worked twice for me (for the first time I thought that something else helped). Scaning problem with MF Toolbox probably will come back after next update, but I'll be prepared for that 🙂


Worked for me as well. Thanks! Wish MF Toolbox would appear so I could choose PDF or Scan, but this is better than nothing.

The worked for me with mf227.  just downloaded windows scan and run it.  Thanks!

@vagabondSteve wrote:

I Upgraded to Win 10 today, so I had this problem too.....however......


OK, so this isn't an exact substitute for the Toolbox....I have an MF4770n.


I did find Win 10 Drivers on this site, so maybe they are new additions.

Download and install the latest drivers for your MF4770n from this site. Restart your PC. Test printing.

Then go to the  Windows App store, search "scan", find "Windows Scan" app, install.


At MF4770n load a doc to scan, select Remote Scanner,

At the PC, open Windows Scan App - it found the 4770n instantly on my system.

Use the drop down menus to select source, output etc. You can preview platen scans, not auto feeder docs.

Doc feeder worked to scan a 5 page PDF first try!


Works for me, hope it does for you.



This worked for me. Thanks!

I had the old MF Toolbox installed I guess, I really don't know as I hadn't used it in a very long time. I was able to print fine, but scanning wasn't working. I downloaded the app from the microsoft store, ran it and it worked without issue.


Thanks again!

The Installation of Windows Scan worked for me as well.  Please note this is different from the Windows Scan and Fax that comes with Windows.  I found it easily in the Windows Store and it scanned flawlessly for me to PDF.






03/30/2023: New firmware updates are available.

EOS R3 - Version 1.4.0

EOS R5 - Version 1.8.1

EOS 1DX Mark III- Version 1.7.1

Speedlite EL-1 - Version 1.0.2

03/30/2023: Product Advisory for EF50 F1.2 L USM

03/30/2023: Product Advisory for EOS R10

03/28/2023: New firmware version is available for EOS-R5 C
03/14/2023: New firmware version 1.8.1 is available for EOS R6
02/24/2023: We've updated Share Your Photos

2/07/2023: New product announcements!

EOS R8 EOS R50RF-S55-210mm F5-7.1 IS STMRF24-50mm F4.5-6.3 IS STMRF15-30mm F4.5-6.3 IS STM
01/18/2023: New firmware version 1.1.1 is available for EOS R6 Mark II
01/09/2023: Help ensure your autofocus is properly aligned with a Canon Precision Alignment
01/03/2023: Welcome to CES 2023!
12/08/2022: New firmware version is available for EOS C70
12/07/2022: New firmware version 1.7.0 is available for EOS R5
11/16/2022: We're thrilled to be ranked among the Best Employers for Veterans in 2022 by Forbes.
08/31/2022: New firmware version 1.1.1 is available for RF 70-200mm L IS USM
08/09/2022: New firmware version 1.2.0 is available for CR-N 300
08/09/2022: New firmware version 1.2.0 is available for CR-N 500
07/14/2022: New firmware version 1.0.1 is available for CR-X300
06/10/2022: Service Notice:UPDATE: Canon Inkjet Printer continuous reboot loop or powering down
06/07/2022: New firmware version 1.3.2 is available for PowerShot G7 X Mark III
05/31/2022: Did someone SAY Badges?
05/26/2022: New firmware version is available for EOS-C500 Mark II
05/26/2022: New firmware version is available for EOS-C300 Mark III
05/10/2022: Keep your Canon gear in optimal condition with a Canon Maintenance Service
05/05/2022: We are excited to announce that we have refreshed the ranking scale within the community!
03/23/2022: New firmware version is available for EOS-C70
02/09/2022: Share Your Photos is back!
01/13/2022: Community Update. We will be retiring the legacy profile avatars on 01/20/2022. Click this link to read more.