cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

MF Toolbox doesn't work on Windows 10

mj1856
Apprentice

I have a MF4570dn, and recently upgraded from Windows 8.1 to Windows 10.

 

I can no longer scan using the MF Toolbox utility.   I had MF Toolbox 4.9 installed before the upgrade, and it worked just fine.  After the upgrade, I get "Cannot communicate with the scanner" error dialog:

 

Error1.png

 

 

 

I thought I would try to reinstall the MF Toolbox utility, but there are two problems.

 

1) The downloads page shows no downloads for Windows 10 for this printer. This should be updated.

 

2) I downloaded the one for Windows 8.1, and tried to reinstall, but it just hangs at the "Processing Installation" screen:

 

Error2.png

 

I've also tried to uninstall the existing MF Toolbox first, and it also hangs at this same dialog.

 

I've also tried various other things without success:

- Connecting via USB instead of Network.  It detects the scanner, and MF Toolbox can switch to that device, but it still gives a communications error.

- Trying the built-in Windows Scan app instead of MF Toolbox.  It uses the WIA driver.  It barely starts to scan, then immediately cancels.

 

Please Canon - forward this to your engineers and provide a fix asap.  I cannot use my scanner on Windows 10.

 

(I can use the printer functionality just fine.)

1 ACCEPTED SOLUTION

Thanks.  My model's links are different, but the new software appears to work.

 

https://www.usa.canon.com/cusa/support/consumer/printers_multifunction/imageclass_series/imageclass_...

 

Also, to get the old toolbox uninstalled, I had to reboot into safe mode.  Otherwise the uninstaller just hung.  Then booted back into regular mode, removed all traces of the existing printer, then reinstalled the new software and it works great.

View solution in original post

434 REPLIES 434

No, no restore point, this was a fresh Windows 10 installed from a previously Windos 7 laptop.

 

There were literally gigs and dozens of development tool installs.  Plus the occasional "This application needs .NET ver... or KB such and such".
Or with Microsoft, even stuff that you don't know about and can't remove.

 

I'm a developer, and I know NOT to rely on MS for much of anything.  If something that my customer needed suddenly didn't work, I'd WANT to know what I did wrong, or what MS did that makes my product fail.

This fix always worked for me. the problem comes back occasionally and I use this fix to correct the problem.

 

FROM CANON COMMUNITY USERS GROUP

(PIERS_A AND CAPTREP)

(FAVORITE IN EXPLORER)

 

‎08-20-2015 04:36 AM

This simple fix I found online worked for me:

 
Start> in the run box type. Services.msc

Scroll down to Windows Image Acquisition (WIA)

Right click, select Properties

Check that Startup type is set to Automatic

Click Log On Tab

Check that Local System account , and Allow service to interact with desktop is checked. Hit apply.

Click Recovery...Click on window next to First Failure, Scroll to Restart the Service. Hit apply.

Yvan67
Apprentice
Thanks for that. I am still having occasional problems. Recently MFtoolbox stopped working again, and finally it did again after a reboot. The windows scanner app does work, but apparently doesn't do multi page pdf scans, which I often need. Hopefully this fix is the end of the problems. Cheers !

I have Windows 10 Home Versioin 2004 !

Microsoft OS Build 19041.685 was installed on 2020-07-23 and my very old Canon Image Class MF4150 is still scanning and printing.

I did have some problems in the past but a firmware update seemed to fix it.

If some geek wants to tell me what and where to look to get the key settings and software versions for MF Toolbox, let me know. I'll try to provide the configuration I have which isn't giving me any problems.

 

I am not wasting more time doing REDUNDANT stuff  

Run as as admin, reinstalled, patch thin, replace that, hack this registry, blah blah blah.

 

NONE of it fixes anything.

 

Canon Toolbox DOES NOT WORK with my Canon device.  I AM WAITING FOR CANON TO FIX IT...  AND CARE

And to rub salt in it.... I was hit wth a "survey" from Canon for the community...  AND IT WON'T TAKE MY COMMENTS.  It says "Authentication Failed"

 

------------------------------------------------

Does ANYONE from Canon monitor this? Can Canon actually show ANY desire to support their product?

For a YEAR the "ToolBox" doesn't work with my MF4895... and yet it's YOUR hardware, and YOUR software... So I'm left out in the cold trying to find some user who cares about my issue more than Canon does.

Maybe there will be a moderator here after Christmas, but as far as I know there isn't anyone in this forum from Canon support. It is basically users supporting users.  Here are the instructions to contact Canon:

 

Canon US

If you cannot solve a problem by referring to the information in this chapter, contact the Canon Customer Care Center at

1-800-OK-CANON, Monday through Friday, between 8:00 A.M. and 8:00 P.M. EST. On-line support is available 24 hours a day at http://canontechsupport.com.

 

Canon Canada Inc., offers a full range of customer technical support options*:
* Available support options are subject to change without notice.
To perform step-by-step troubleshooting, send e-mail to technical support, download drivers or support documents, or view answers to frequently asked questions, visit http://www.canon.ca/
Free live technical support is available from 9 A.M. to 8 P.M. EST, Monday through Friday (excluding holidays), for products still under warranty 1-800-OK-CANON
To find the location of the authorized service facility nearest you, visit http://www.canon.ca/ or call 1-800-OK-CANON.
If the problem cannot be corrected via these technical support options, repair options are available from the technical support personnel via the website at http://www.canon.ca/
 

Please have the following information ready when contacting the Canon Customer Care Center:

Product name (imageCLASS MF4890dw/MF4880dw/MF4770n)

Serial number (a character string of 3 letters and a 5-digit number; located on the rating label on the rear side of the machine.)

 

olddognewtrix
Apprentice

I was able to resolve this by giving the user modify access in the application security properties after comparing the groups that had access to the application for a computer that it worked on. Additionally, adding the users group with the same permissions would also likely resolve this.

Briefly, my fix:  MF Network scan utility needed to be run as admin.

Maybe this will help some of you.

My issue was specific to scanning from the unit itself, not the MF Toolbox which worked fine.  However, I did receive the same message as many here.

"MF Toolbox that is supported by the scanner you are using may not be installed on your computer.  Install the appropriate MF Toolbox, and then perform the operation again."

 

For the MF4880dw.  This had worked until 2019; Windows updated; broke; found network patch many others mentioned here as well as updated firmware and software; worked until 8/9/2020 when I got Windows 1909.  I just tried 20H2 thinking maybe that would help.  Nope.  Windows often updates security as it should.  Not all programs are written with this in mind.

 

I had previously tried running the MF Toolbox as an admin (compatibility, all users, as someone else here mentioned) but the problem according to procmon was that mf network scan wasn't able to fire off MF Toolbox.  Tried UAC, etc, nothing.  That's when it occurred to me it wasn't mf toolbox for me, it was the network scan.

 

To do this for testing:  close CNMFSUT6.EXE in task manager, then right-click this file and run as admin.  Try the button on the scanner again.  If it works, that's the issue, if not, don't bother continuing to read.

File:  C:\Program Files\Canon\Canon MF Network Scan Utility\CNMFSUT6.EXE

Fix permanently for every reboot:

Right-click "C:\Program Files\Canon\Canon MF Network Scan Utility\CNMFSUT6.EXE"

Compatibility tab

Change settings for all users

Run this program as an administrator

OK, OK

 

If this helps, you're welcome... if not, I wish it had, I know how flippin' irritating broken software can be.  Thank you to all the posters who shared their own fixes.  olddognewtrix - I replied to your post because it sounded similar to where I was headed.

 

ADDENDUM:  I have not tested yet but it's possible installing everything as admin might help - not just logged in as one, but right-clicking each installer and doing "Run as admin."  Kudos to husband for that idea.  I've seen it work that way, too, and was surprised I hadn't thought to try it.

Dear Nvnohi,

 

I have no idea who you are, but you rock!!!   THIS FIXED IT!!!  Thank You!!!

 

I've done network programming for decades, but there was nothing that documented what that utility was for.  And since it showed me the scanner, I figured it was talking just fine.  I guess that silly little utility is some kind of "pass through".

 

-Scott

Avatar
click here to view the press release
Announcements